1

When trying to install new extensions through Magento Connect Manager, the page shows a login prompt. Upon logging in the page will just reload without installing or doing anything. The same behavior happens when trying to update existing extensions.

I have tried various solutions and nothing seems to work. Please help.

I should also mention that this site was moved to a different IP and domain name than that of the original.

  • I had the same problem. Folder var was with permissions 755. I changed recursively on the 777 and the problem was solved. – Oleksandr Dykyi Dec 17 '15 at 9:52
3

First, start with @thebod's answer and check the base_url settings. But for me, I also had to put the domain in

 System > Configuration > General > Web > Session Cookie Management > Cookie Domain.

Many features of Magento will work with this field empty, but I had to put my domain in that field to get Magento Connect Manager to not do a login loop.

2

This sounds like an issue with the cookie domain.

My advise is: make sure every base_url is set up correct (check the database). Clear the whole Magento cache (folder: var/cache/). There is also a cache.cfg inside the downloader directory, please try to delete this one as well.

Afterwards delete all the cookies that might be related to the new domain. Then try to login again.

Also I'd suggest you to use the mage script via SSH:

cd /path/to/magento
chmod +x ./mage
./mage mage-setup
./mage install community VendorPrefix_PackageName

E.g.: ./mage install community Thebod_Shippingratesor something similiar.

  • Thanks for the reply. I was unable to find any mis-configured base_url settings in the database as well as in the admin section. I have tried clearing the var/cache and var/session folders several times along with deleting the cache.cfg and even going so far as to download a fresh clean magento install and replace the downloader folder. I did notice previously that I was able to get it working by completely clearing cache/session and all browser data and going straight to domainname.com/downloader However if I tried going through the backend first it would cause this issue. – UnknownDev Jul 8 '13 at 21:02
  • Maybe something wrong with the serverconfiguration? I would try to sniff all the requests and check what cookies are transferred, on client as well as on serverside. Also try it with different up-to-date browsers. Unfortunately I can only speculate about the problem, I have no chance to try it myself. – thebod Jul 10 '13 at 7:07
1

The issue is with the default store view set in Configuration -> Manage Stores -> Main Website Store. If the Store View has a different URL and is set as default for the “Main Website Store”, the Downloader will try to execute in the context of that domain.

Either login through the default Store View URL or change the default Store View in the “Main Website Store”.

Source: http://www.magentocommerce.com/boards/viewthread/59179/P15/#t426336

  • Our website only has 1 store view. When going to the specified area I do not see any option to change the Store View URL. How can I change this? – UnknownDev Jul 1 '13 at 18:54
1

I fixed this up by clearing my cookies. There were two php cookies confusing each other.

Press F12 > network, Login and then click on the POST request and check the cookies

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.