0

I have 2 Magento stores on the same server, Ubuntu, on AWS. The system runs with Nginx and PHP-FPM.

One of the shops have a problem in creating invoices. Every time I click Submit Invoice or Submit Shimpent, the site generates Internal Server Error and the server goes down. What could it be?

The php logs, Nginx and Magento say nothing.

0

You're running out of memory. Any time a 500 error doesn't create a log entry it's due to not having the resources to complete it. Try increasing your PHP memory limit to 2048M or higher to see if that works. If that works then adjust it down to a more reasonable number for your server's config.

  • thanks, but, still loading , for minutes , and does not generate anything. – luiza Jan 24 '15 at 1:19
  • In your index.php, uncomment ini_set("display_errors",1);. If it outputs an error message then post it here. – seanbreeden Jan 24 '15 at 18:00
  • It is already on this mode, to display errors, the problem is that the load never ending, its like a loop, and, when I close the window or back to another page the site are on Internal Server Error – luiza Jan 24 '15 at 18:26
  • Try increasing your execution time: ini_set ("max_execution_time",14400); – seanbreeden Jan 25 '15 at 0:34
  • still loading without response. So, I wait 10 minutes, and nothing. When I close the window and reopen the site is down, and I just need to restart php5-fpm and it back to work. And, when I look to the order the status are changed and the invoice are generate. – luiza Jan 26 '15 at 15:19
0

Try this setting in php.ini

extension=pdo.so
extension=pdo_sqlite.so
extension=sqlite.so
extension=pdo_mysql.so
memory_limit = 8192M
max_file_uploads = 5000
upload_max_filesize = 512M
max_execution_time = 72000
mysql.connect_timeout = 2400
post_max_size = 512M
  • Please explain why changing settings like the max_file_uploads would have an effect here. – Tyler V. Oct 15 '15 at 19:11
  • you can leave these setting because my requirement upload 800 products upload via CSV thats why i'm using these setting. max_file_uploads <br /> upload_max_filesize <br /> mysql.connect_timeout <br /> post_max_size <br /> – Usman Fayyaz Oct 16 '15 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.