I have 2 stores on a my Magento setup ver.

http://www.gmesupply.com and http://www.colsafety.com

I am trying to use the option "Use Categories Path for Product URL" NO for both store but the rewrites are not being created correctly for one of the stores.

Colsafety.com creates rewrites for all of the product pages. Gmesupply.com only creates rewrites for URLs containing categories.

For example... Colsafety rewrite:

67600-elkriver-peregrine-platinum-harness --> catalog/product/view/id/3718

Gmesupply rewrite:

safety-equipment/harnesses/elkriver-67600-peregrine-platinum-harness --> catalog/product/view/id/3718/category/12368

Both stores use the exact same product database so I'm not sure why it's working for one and not the other. I have made sure setting are correct under both store views. I have tried emptying the core_url_rewrite tables, reindexed, and cleared the cache.

Any ideas on why it isn't working on GME Supply?

1 Answer 1


Setting Use Categories Path for Product URLs to No will have no effect on the contents of the core_url_rewrite table. Magento will always generate all possible URL combinations, no matter what the settings are. From what I can tell, this setting is only forcing Magento to return direct product URL when getProductUrl method is called on a product model instance.

You can check by executing following query:

SELECT * FROM core_url_rewrite WHERE product_id = 3718;

This should produce multiple results depending on how many stores and categories are involved.

  • Here's what I got gmesupply.com/images/screenshot-table.JPG Jan 22, 2015 at 22:05
  • Can you recommend where to edit gmesupply.com so that it pulls the direct product URL? Jan 22, 2015 at 22:06
  • It's really hard to tell as this should work out of the box. Which page is in question? Jan 22, 2015 at 22:34
  • It isn't working for any products on gmesupply.com at all. It won't automatically create redirects for direct product URLS. It will only create them for Columbia Safety. Jan 22, 2015 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.