0

we're having a problem that an error message shows after enabling and disabled the Compiler in Magento (at least we think that's the reason).

The error message reads as follows:

Warning: include(Mage.php): failed to open stream: No such file or directory in <absolute path to Magento>/lib/Varien/Autoload.php on line 93 Warning: include(): Failed opening 'Mage.php' for inclusion (include_path='<absolute path to Magento>/app/code/local:<absolute path to Magento>/app/code/community:/<absolute path to Magento>/app/code/core:/<absolute path to Magento>/lib:.:/usr/share/php:/usr/share/pear') in /<absolute path to Magento>/lib/Varien/Autoload.php on line 93 Fatal error: Class 'Mage' not found in /<absolute path to Magento>/app/code/core/Mage/Core/functions.php on line 244

For whatever reason the error didn't show up ever before. As said, we were enabling the compiler but disabled it right after.

What we did next was to clear the compiler files through the shell:

php -f compiler.php clear

We did check all the file's location and permissions and they seem fine. We do not have any ideas anymore what could be causing this.

Any idea on what could be causing the error? Thanks a lot!

2

Sorry to have bothered you all.

The issue obviously was setting "Allow symlinks" in the Magento admin to Yes. Just set it to No, and it's working fine again.

  • Please select your own answer as "accepted" to mark this question as resolved. Thanks! – Anna Völkl Nov 20 '14 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.