3

I recently started working Ubuntu and installed Magento here. Everything is ok until I tried to install an extension by manually putting files in particular folders, but when I go to admin, the extension is not showing there. Then I went to system->configuration->advance and I saw that module wasn't registered there.

For this I also made all the file permission to read and write, but still the extension is not showing in admin panel.

  • 1
    Please flush your cache. If it still doesn't work, paste the xml code of your module registration located in app/etc/modules. – Nasir Perwaiz Jan 19 '15 at 14:08
  • check file permission – Amit Bera Jan 19 '15 at 14:10
  • is it custom extension ? – Siddharth Vaghasia Jan 19 '15 at 19:05
  • hello Amit i already checked the file permission. siddharth I am trying to install the magentothem new product slider this package i downloaded from their site. – Ratnesh Choudhary Jan 20 '15 at 4:28
9

Ideally you want to test installing it on a development server which is not your live site, so you can make sure there are no conflicts with your existing system. But in general, here are some steps to make sure that everything goes smoothly:

  1. If it is turned on, disable compilation before installing your extension manually (System -> Tools -> Compilation)
  2. Make sure you are using the Ubuntu "cp" command properly to copy the files into the appropriate directories.
  3. When you have copied all the files, clear the store cache, log out of the admin and log back in.

If at this stage, you still do not see the module name showing up in System -> Configuration -> Advanced this means that Magento is not picking it up from the app/etc/modules folder.

Go into {docroot}/app/etc/modules and open up the XML file from the module that you copied in there. Make sure that the XML node for is set to true and also since you're on Ubuntu, run xmllint on the file also to make sure it is valid XML.

Beyond that any problems that exist may be part of the PHP code.

2

In addition to @Talesh explanation I would like to mention something that was driving me crazy long ago and I recently saw again: Make sure that the file name in app/etc/modules/[Namespace]_[Module].xml match the namespace and module in

  <?xml version="1.0"?>
    <config>
        <modules>
            <[Namespace]_[Module]> <!-- Equal to this -->
              ...
            </[Namespace]_[Module]>
        </modules>
    </config>

Same goes for the the configuration file in app/code/[codePool]/[Namespace]/[Module]/etc/config.xml and its content

<?xml version="1.0"?>
<config>
    <modules>
        <[Namespace]_[Module]>
            <version>1.0.0</version>
        </[Namespace]_[Module]>
    </modules>
    ...

Pay special attention to capitals and lowercase characters in files and folders name as well as module configuration and declaration files. In all cases they need to match. Hope it helps

0

Bit of a rookie mistake here on my part. But, thought I would post my solution anyway.

As mentioned file permissions were set correctly.

However, also make sure that the file/folder ownership of the extension are set correctly to your webserver user ie. chown -R www-data * in your magento root.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.