2

ive managed to use the profiler for CSV import on magento - when i run and execute the file i get this

http://imgur.com/UlyPREu

So the data processes 100% (i dont think images are crucial for products going live) but the new products do not import despite processing.

When i run the CSV against the regular import and data check, i get this:

Column names: "" are invalid

this is a screenshot of the data i am trying to import, i want to keep column headers if possible:

http://i.imgur.com/XNJPBdN.png

many thanks

  • I'm guessing you might have an extra column at the end of your document? Open the CSV in notepad (or something similar) and see if you have a hanging comma at the end that is adding a blank column? – Douglas Radburn Jan 14 '15 at 13:32
  • nope that dcoesnt seem to be it Douglas but appreciate your help – chrisAVF Jan 14 '15 at 13:38
  • I'll get that error when I forget to have LibreOffice save the file as UTF-8. – chaoticgeek Jan 14 '15 at 14:03
  • You should provide your csv or a sample of it (including headers). Possible reasons: wrong charset (should be UTF-8), BOM (should be no), invalid header row, ... – Andreas von Studnitz Feb 14 '15 at 21:42
  • Make sure column headers are formatted to "General". – user42561 Jul 25 '16 at 7:10
1

From my experience I have never had any luck with using the dataflow profiles. I use the normal import with Entity type of Products and Append complex data options set. Your CSV must have headers in it.

You can try this sample below to get you started.

sku,_store,_attribute_set,_type,_product_websites,price,status, visibility 1234,,Default,simple,base,1.99,1,4

0

Open your file in Notepad++, Here you can see missing fields. See lines. Sometimes we cant find mistakes in office. So use notepad++. This is work for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.