2

I've downloaded the latest CE version 1.9.1.0, and successfully patched the installation with the SUPEE-4829 patch.

I see 2 other patches that could apply to 1.9.1 - SUPEE-1533 (Addresses two potential remote code execution exploits) and SUPEE-4291/4334 (This patch addresses the USPS API changes...). I've tried to apply these patches but get these error messages:

SUPEE-1533.sh

Checking if patch can be applied/reverted successfully...
ERROR: Patch can't be applied/reverted successfully.
patching file app/code/core/Mage/Adminhtml/Block/Dashboard/Graph.php
Reversed (or previously applied) patch detected!  Assume -R? [n] 
Apply anyway? [n] 
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file app/code/core/Mage/Adminhtml/Block/Dashboard/Graph.php.rej
patching file app/code/core/Mage/Adminhtml/controllers/DashboardController.php
Reversed (or previously applied) patch detected!  Assume -R? [n] 
Apply anyway? [n] 
Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file app/code/core/Mage/Adminhtml/controllers/DashboardController.php.rej

SUPEE-4291/4334

Checking if patch can be applied/reverted successfully...
ERROR: Patch can't be applied/reverted successfully.
patching file app/code/core/Mage/Usa/Model/Shipping/Carrier/Usps.php
Reversed (or previously applied) patch detected!  Assume -R? [n] 
Apply anyway? [n] 
Skipping patch.
patch unexpectedly ends in middle of line
2 out of 2 hunks ignored -- saving rejects to file app/code/core/Mage/Usa/Model/Shipping/Carrier/Usps.php.rej

These patches were made executable (chmod +x scriptname.sh), and were run using both sh scriptname.sh and ./scriptname.sh, but I still get the same messages.

I'm breaking my head over what could be wrong with the shell scripts, so are these patches severely important?

thank you

10

The other 2 patches (4291 and 1533) were issued for Magento 1.9.0.1 and earlier actually. They are already incorporated into 1.9.1.0, which is why you cannot successfully patch them in 1.9.1.0. The versions listed on the download page are a bit mis-leading.

  • Thanks Rob! At least I dont need to worry about them then. You are right in that is a bit misleading as the 'select format' dropdowns are marked 1.9.x – maGz Jan 14 '15 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.