3

I have a store where product quantity are set to 0. I have enabled back orders if qty is 0 for a product, however I would like to disable Add to cart in case product is out of stock. This means Add to cart is only available if qty is 0 and In stock is selected in Product Inventory tab. I tried to change couple of settings in System -> Configuration -> Catalog-> Inventory but unable to enable such rule.

Any one who could help?

Thank you

1

By default in Magento, if you go to System -> Configuration -> Catalog -> Inventory and set Backorders to "Allow Qty Below 0", and on the product page in the inventory tab you have the following settings:

enter image description here

then, the product should show as "In stock" on frontend and the customer should be able to add it to cart:

enter image description here

By changing the Stock Availability of the product to "Out of stock" you should be able to get it to show as "Out of stock" on the frontend:

enter image description here

Are you trying this with the default Magento theme? If you are using a custom theme and this is not happening for you with these setting there might be a problem in the theme you are using.

  • Thank you for the post. I have magento rwd theme enabled. When I change Stock Availability to 'Out of Stock', and save it, the value after saving the product shows 'In Stock'. For some reason it doesn't change to 'Out of Stock'! – harry Jan 27 '15 at 5:31
  • Are you able to save any other attributes for the product? Do you have any custom modules installed? You can also try enabling the log files and check them after saving the product. – Marina Vilcea Jan 27 '15 at 17:55
  • I have to unchecked 'Use Config Settings' for Backorders: and change value to No Backorders for specific product. Thereafter change Stock Availability to Out Of Stock. After this, product is out of stock and add to cart is disabled in frontend. Thank you for your inputs. – harry Jan 28 '15 at 10:55
  • You're welcome. I'm glad you found the solution to your problem. – Marina Vilcea Jan 28 '15 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.