2

I had created some custom attributes in my 1.9.1 install (basically for item color and size). Well, I've noticed that upon trying to create a Configurable Product, I get this error:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 360169 bytes) in /home/(sitename)/public_html/app/code/core/Mage/Core/Model/Translate/Inline.php on line 207

Then when I go into the inline.php file, I see this on line 207:

$body = preg_replace('#' . $this->_tokenRegex . '#', '$1', $body);

I've changed the memory in the php.ini file and the .htaccess to 512M, and the .htaccess to the actual bytes number.

I'm now out of ideas. Any help would be awesome.

  • You could check what exactly this function is trying to process (log the $body variable). There could be problem with input text length. – DmitryR Jan 13 '15 at 17:35
  • 1
    Thanks DmitryR. I re-checked a couple things in the code and it appears I had changed the memory amount in only one of them. So now it's allowing me to create the configurable product. However, after I place all of the info and go to save it, I get a blank page. Then if I go back to the Products page and click edit, I get the same blank page. :( – Taleyeh Jan 13 '15 at 17:48
1

create a file info.php in the magento root and write this code

<?php
phpinfo();

then open it from the browser and check if the memory limit has been really changed. Sometime you need to edit the right php.ini accordingly to your php version.

  • Antonio, that helped alot. Ok, so I have PHP Version 5.4.35, and the memory limit shows 32M. So, where exactly am I to change this? I thought the two places I changed them was the proper place, but I'm guessing it's not? – Taleyeh Jan 13 '15 at 22:36
  • check in info.php which is the php.ini path – Antonio Pedicini Jan 13 '15 at 23:56
  • In the phpinfo output, you will see the php.ini file location. You should open it with text editor, locate the 'memory_limit = 32M', and change 32 to something bigger - 128, for example. – DmitryR Jan 14 '15 at 9:57
  • magento needs 512M, check also your hosting resource limits – Antonio Pedicini Jan 14 '15 at 11:49
  • Ok apparently the 'php.ini' file actually was 'php.ini.sample.' So in the [file info.php] I see the memory has changed to 512M. BUT...now I get a 'There has been an error processing your request. Exception printing is disabled by default for security reasons. Error log record number: 396530251831' error now. – Taleyeh Jan 14 '15 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.