3

After many hours of googling and experimenting I have no ideas what else could be wrong. When I try to upload product images I get:

SSL Error: Invalid or self-signed certificate.

  1. It's only visible while basic auth in .htaccess is enabled. Otherwise there is no (success/error) message and no "remove" button.

  2. I have disabled secure URL - it's the same as unsecure URL and set "Allow secure url in admin" to No.

  3. My max upload (in PHP) is set to quite big file size;

  4. Permissions are also set properly.

  5. I have disabled mod_ssl for apache (restarted after that of course);

  6. I have no configs for SSL in /sites-enabled/ files.

There is only problem with Flex Uploader (product images multi upload) and I have no idea how to debug this flex/flash upload.

Does anyone have any good ideas that allow me to fix this on test server (it's OVH).

4

I had the same problem with EI and Firefox but when I switched to Chrome all was ok. So I guess this could be browser incompatability.

2

Solution:

  • Check you have enough file space in the /tmp of your server.
  • Do a phpinfo() and php -i | grep upload_tmp_dir to check where your upload_tmp_dir is set to and make sure it's writable.
  • Make sure folders media and var are writable in your project webroot.
  • Install php5-gd sudo apt-get install php5-gd.

Resources:

1

It's an odd error to get and quite misleading, but it will be being caused by Basic Auth, since the flash file uploader doesn't have the authentication data when it makes requests to the server. From what I understand, one way to work around the issue is to allow POST requests, by using LimitExcept as part of your Auth like the following:

AuthType Basic
AuthName "My Magento Store"
<LimitExcept POST>
    Require valid-user
</LimitExcept>

However since this essentially allows all POST requests through, it's not ideal, as a shrewd hacker could theoretically just force all requests they made to be POST (assuming they could work out that POST requests are allowed through). A better solution would probably be to allow through just the URL that the flash uploader will request, however I've never had any luck at all allowing mod_rewrite rewritten URLs with the Satisfy / Require directives of mod_auth. I requested help with it from Rackspace dedicated support (we wanted to allow through certain callback URLs for remote services), but even they weren't able to offer a solution.

  • The problem is that it event not working when Basic Auth is turned off/disabled. – Filip Górczyński Jan 13 '15 at 9:58
  • and you've disabled all SSL reference and cleared the cache? – Peter O'Callaghan Jan 13 '15 at 10:24
  • Yes I did. And I found a solution (with my friend help). There was no php5-gd on dedicated server. PHP5 GD is not used when uploading category images. – Filip Górczyński Jan 13 '15 at 11:26
1

In my case the problem has nothing to do with SSL.

Large file upload you have to set some PHP ini settings:

Upscale this settings to for example

php_value upload_max_filesize 20000M
php_value post_max_size 20000M

php_value memory_limit 256M
php_value max_execution_time 18000
0

There was no php5-gd on dedicated server. PHP5GD is not used when uploading category images. Installing PHP5GD solved product images uploading.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.