3

I am getting an error after compilation. I am using Magento 1.9.0.1.

My website was running too slow so I have complied but after compilation my website (frontend as well as backend) has down and showing the same error. Please help me to rectify the same.

Error: Fatal error: require_once(): Failed opening required '/home/ecomventures/public_html/demo/includes/src/../lib/vendor/autoload.php' (include_path='/home/ecomventures/public_html/demo/includes/src:.:/usr/lib/php:/usr/local/lib/php') in /home/ecomventures/public_html/demo/includes/src/Fontis_Australia_Model_Observer.php on line 23

  • 5
    Compilation is no longer considered a Magento "best practice". I would argue that you should not use it and find other, more modern, methods of achieving the speed increase you're looking for. – philwinkle Jan 12 '15 at 19:59
  • 1
    Compiler was a kludge introduced around 1.4.1.1 and Magento was optimized to the point that it started to become mostly useless in 1.6.2.0 per A/B testing. The problems it introduces when 3rd party modules start being introduced to the mix often means it needs to be tossed in the corner where it belongs as a side note of history. – Fiasco Labs Jan 13 '15 at 6:15
2
  1. Open the index.php in your magento store Comments the below lines.

/** * Compilation includes configuration file */

/**
$compilerConfig = ‘includes/config.php’; 
if (file_exists($compilerConfig)) { 
include $compilerConfig; 
} 
*/ 

Clean the cache dir and verify that its now working.

  1. Another options, if you are able to open backend then go and disable complier
  2. Disable via terminal $ php -f shell/compiler.php -- disable php -f shell/compiler.php -- clear php -f shell/compiler.php -- state

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.