0

We have a Magento installation that has 2 websites (IDs 1 & 2 in core_website), each has 1 store (IDs 1 & 2 in core_store), with the ID's of the stores matching the ID of the website it's associated with. I recently noticed that we have occurrences of customers who's website_id doesn't match their store_id in the customer_entity table. It's only ~0.05% of customers, but I can't work out how this could be possible. If somebody is registering from Store 2 this should surely necessitate that they are registering from Website 2.

Can anybody shed some light on how this might occur and perhaps more importantly whether it can lead to any problems?

  • Are there any users that are assigned to the store_id = 0? – DmitryR Jan 12 '15 at 14:05
  • A handful, but the majority are 2 & 1. We actually checked a different client and can see they have the same 'issue'. – Peter O'Callaghan Jan 12 '15 at 15:03
  • It won't cause any problems if Share Customer Accounts is set to Global (Configuration > Customer Configuration). – Maikel Koek Jan 12 '15 at 16:03
  • Which it is. Do you have any idea what causes it? – Peter O'Callaghan Jan 12 '15 at 16:40
0

After looking into something completely unrelated, I have come across the reason behind this. Mage_Newsletter_ManageController::saveAction, which is triggered by saving the Newsletter subscription tab in the customer account changes the store_id of the customer to match the current store.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.