I'm getting an error on a field when I try updating products during an product import.

  Skip import row, is not valid value "" for field "type"

I'm using sku to identify the product that I want to update and the other fields are the fields that I want to update


  "sku123","some title for meta","a description","keywords go here"

The import contains 312 rows and at the bottom of the import page it says - Processed 100% 312/312 records. But after that it tells me - Imported 199 records.

I don't understand why field 'type' is causing an issue. I checked all of the stores products and they all have a type set. The data contains no special characters. It is saved to csv and formatted in utf-8.

  • you should probably specify a type_id for your products, like "simple". Commented Jan 8, 2015 at 16:44
  • this is already set for the products in the system. Surely setting it in the csv would only overwrite this, no? Commented Jan 14, 2015 at 9:23
  • What do you mean by "this is already set for the products in the system" ? Commented Jan 14, 2015 at 13:17
  • well i'm running an update on products rather than importing new products. What I mean is that the products being updated already have a type eg. simple or configurable. Maybe I'm misunderstanding you? Commented Jan 14, 2015 at 13:56
  • No I actually misunderstood you. Then I can't quite tell you what's wrong, I'm not a fan of Magento Dataflows. Have you tried looking into your system.log or exception.log to see if something was wrong? Commented Jan 14, 2015 at 14:32

5 Answers 5


Skip import row, is not valid value “” for field “type”

You may get this message if you download the export file from Magento and ammend the file and try re-importing it.

How to Fix.

Make sure the column names names do not start with an underscore in your import file.

An example would be the type column – which should be “type” not “_type”.

Same for other column headers in the import file, make sure they do not start with an underscore


I had the same issue due to the fact that the SKU did not exist. Check to make sure there are no trailing spaces, or the case is correct. Also, if you exporting from Microsoft Excel, the file format could be an issue. Try to create a file in Google Sheets, and export form there.


I don't have a concrete answer for this but seeing as I did eventually solve the issue and there is no other answers here I will post what I did and hopefully it will help someone else.

The spreadsheet was originally created in excel on a windows machine. Then converted to csv on a mac and then imported. I basically repeated this process quite a few times and on one of them it eventually worked.

I don't know for certain what I did differently but my steps were to choose utf-8 format. Select comma sperator and quote columns. I'm certain I did this each time but either there is something else to it or I was doing it wrong before. Anyway these are worthwhile checks to ensure you've done because after enough trial and error it did work for me by following this process.


I had this warning because my field mapping had a different order than the CSV file. So the first mapping needs to be the first column in the CSV file.


I'm putting this here because I've come across this several times myself, and it still catches me out.

If you've checked that all the fields are correct, make sure that you have matched the Value Delimiter (Field Delimiter) in both Magento and .csv file

By default it is ,

I find I have more success rates using \t {tab}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.