6

I'm trying to move my Magento store from local to web server. But I run into a problem:

The install wizzard pops out, I can't figure out why.

What I tryed till now:

  • Double checked the database settings - OK.
  • Mage.php exists in app folder.
  • Deleted files from /var folder - left only the folder's.
  • UPDATE: Changed permisions to 777 - Problem remains...

Thank you guys.

here is the content of local.xml, maybe there is a problem? I've changed the Host, user, pass and db.

<config>
<global>
    <install>
        <date><![CDATA[Wed, 08 May 2013 17:08:50 +0000]]></date>
    </install>
    <crypt>
        <key><![CDATA[e90bf233553fe3516b20edc85438eb3d]]></key>
    </crypt>
    <disable_local_modules>false</disable_local_modules>
    <resources>
        <db>
            <table_prefix><![CDATA[]]></table_prefix>
        </db>
        <default_setup>
            <connection>
                <host><![CDATA[127.0.0.1]]></host>
                <username><![CDATA[root]]></username>
                <password><![CDATA[]]></password>
                <dbname><![CDATA[todoiphonestore]></dbname>
                <initStatements><![CDATA[SET NAMES utf8]]></initStatements>
                <model><![CDATA[mysql4]]></model>
                <type><![CDATA[pdo_mysql]]></type>
                <pdoType><![CDATA[]]></pdoType>
                <active>1</active>
            </connection>
        </default_setup>
    </resources>
    <session_save><![CDATA[files]]></session_save>
</global>
<admin>
    <routers>
        <adminhtml>
            <args>
                <frontName><![CDATA[admin]]></frontName>
            </args>
        </adminhtml>
    </routers>
</admin>

Update and solution: If you'll take a closer look to the local.xml I've pasted you'll see my mistake, I was mising one of the ] sign's in <dbname> so Magento couln't connect to the database... When I added this symbol, everything became normal. Well, few more minor issues, but the main problem was solved.

  • Does your app/etc/local.xml files exist and have reading permissions for the user under which the web server is running? – Foo Bar Jun 25 '13 at 17:22
  • The file exist, at the moment I'm updating all the files to permisions 777, I've spotted that not all were with this permision's. I'l make an update in few minutes. Maybe it will solve the problem... I hope. – Artur Rain Jun 25 '13 at 17:25
  • @Tim: I think the original post said that the 'downloader' starts. This usually happens when you don't have Mage.php in the right place – Marius Jun 25 '13 at 17:25
  • @Marius: I have the Mage.php in /app folder. – Artur Rain Jun 25 '13 at 17:27
  • @ArturasStrazdas, please post the solution you found as an answer and your question about CSS as a separate questions. I cleaned you brainstorming in comments, sorry :-) – Foo Bar Jun 25 '13 at 20:44
3

To get yourself working again roll back your module and check in core_resource to make sure your module is at the correct version.

I've seen this myself quite a bit. 1) Do these things in off-peak. Yes, I know, it's a pain. 2) It's crucial when doing install script-based deployments that you adhere to the following workflow:

  • Disable all caches
  • Switch site into maintenance mode
  • Kick off your code update (svn up or git pull origin master or whatever else you do)
  • Kick off Magento's update with a simple > php index.php from the site root.
  • Flush the cache again. Use N98-Magerun or Mage_Tool or another package to do this from shell.
  • If you're using memcached/Redis, flush those, too.
  • Remove maintenance.flag

However, most times I've been stuck in an install file error loop to poorly written upgrade routines, and not due to cache:

  • Not having tested, multiple times, in dev, staging, qa before production push
  • relying on tables / data to exist
  • writing unsafe SQL
  • Not having error handling
  • Not using transactions
  • Not using INSERT IGNORE or ON DUPLICATE
  • Thank for the sugestions. But I solved it. – Artur Rain Jun 26 '13 at 6:55
1

I was having this problem after setting up a copy of my site on my local computer.

Turned out the name of the database on my local server was longer than the 16 characters allowed, and MySQL was only recognizing the first 16 chars. Since Magento couldn't find a database with the name I'd specified, it assumed I wanted to install Magento instead. Everything worked once I renamed the database and change the DB name in local.xml.

0

Also check your <date> format on app/etc/local.xml file.

If strtotime('yourvalue') returns false, Magento will redirect to install.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.