0

I have followed all the links related to this but I am not able to install. I am installing on the godadday hosted account. On the first installation page I am getting "No Input file specified". Can u pls specify step by step procedure to install.

2
  • Instructions here will be probably the same, it would be better to list what you have done / tried, other issues you have noticed,... so we can start off from there. Commented Jun 25, 2013 at 11:51
  • I have added RewriteBase / ,Options -MultiViews in htaccess file. Created php5.ini and added cgi.fix_pathinfo = 1 Commented Jun 25, 2013 at 12:41

1 Answer 1

2

This video has a step by step overview on how to set it up:

http://www.youtube.com/watch?v=YicBzxnrnOM

Your particular problem is well-known and has been documented in a few places including the Magento Wiki:

http://www.magentocommerce.com/wiki/groups/227/error/no_input_file_specified

From the article:

add this to your .htaccess file

RewriteEngine On
RewriteCond %{DOCUMENT_ROOT}%{REQUEST_URI} !-f
RewriteRule ^.+.php$ /bogusfile

Then try to reload your setup page.

If you do not have Magento setup in the root of your server, make sure to add the following to your .htaccess file.

RewriteBase /yourbasepath/

Once that is verified, there are a couple things you can do to fix this, but we’ll start with the one that usually works.

In your web root directory, there should be a file called php.ini. Rename this to php5.ini.

If there is no php5.ini file. Create the file and upload it to your root directory.

If that doesn’t work, add the following to the end of your newly renamed php5.ini file:

cgi.fix_pathinfo = 1

And if you’re still getting the error, add the following to the top of your .htaccess file:

Options -MultiViews

The first one usually does the trick. If you don’t see this file in there, then create a blank php5.ini file add add the line listed on the second suggestion.

If all of the above has not worked, KEEP your changes, wait exactly 24 hours. Go back to youraddress.tld/downloader and try again. You may just be cached and for some reason it takes a bit longer then I was used to. Keep your chin up!

If nothing above worked, call GoDaddy up and have them either rename this for you, or make sure you’re on PHP 5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.