3

I have a script that bulk creates attributes and sets in Magento. The attributes and their sets look fine, and the settings are correct. When these attributes are created, I use AMartinez's customimpertexport script to bulk import products. These products do have the attributes correctly filled in.

If I look at a product in the back-end, they are there, with the correct values. When I take a look at the front-end however, the values are not displayed. Also, the layered navigation does not work (probably because of forementioned bug).

This makes me think there is something going wrong with linking attributes to products.

Since I'm pretty new at Magento, I don't know very much of it yet, so any explanations on how or why would be apreciated.

2

Make sure you set the correct values for the attributes.
I mean, if you want them to be used in layered navigation, you should set Use In Layered Navigation to 1 (Filterable (with results)) or 2 (Filterable (no results)).
If you want the attribute to be available in product listing set Used in Product Listing to 1 (Yes).
If you want the attribute to be listed in layered navigation for search set Use In Search Results Layered Navigation to 1 (Yes).
If you want the attribute to be listed in the product details page set Visible on Product View Page on Front-end to 1 (Yes).
After an attribute generation and a product import you should reindex everything.
And clear the cache just in case.

5
  • The attributes do have the correct values. When I check the attributes in the back-end, the settings are correct. Use in layered navigation is filterable with results, used in product listing is yes, search results is yes and visible is yes. Cache is disabled (but cleared anyway), and indexes are regenerated. They still do not show up. Jun 25 '13 at 8:31
  • In this case ...I'm out of ideas. +1 for the question since I'm also curious to why is this happening.
    – Marius
    Jun 25 '13 at 8:40
  • I found out that the table catalog_poduct_flat_1's values for the attributes are all empty (NULL). So somehow it doesn't create the indexes as it should.. 1 step further, now find out where and why... Jun 25 '13 at 8:43
  • If you disable the flat products, does is look ok? Anyway...you should check var/log for errors (if you have the error logging enabled).
    – Marius
    Jun 25 '13 at 8:45
  • It's still the same, and the same effect with flat products disabled. Log doesn't show anything wrong. Jun 25 '13 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.