2

I manage my website with magento but I tried to connect to my page and I have the following message ;

Fatal error: Class 'Mage_ConfigurableSwatches_Helper_Data' not found in /home/jmellman/public_html/app/Mage.php on line 547

It happened just after I try to upload files from an extension and I flushed the cache and enable compilation but when I refreshed the page I had the message.

How to fix the problem ?

  • This is not a solution, but try to go to app/etc/modules/ and find the .xml file of the module that you tried to install. If it is named yourmodule.xml just rename it yourmodule.xml.tmp (this should disable the extension) and see if you can access the frontend again. I think something went wrong with your module installation. Tell us how you installed it. – ForMat Jan 6 '15 at 20:21
  • In extension user guide I followed the steps;I upload the files and I had to flush the cache and if necessary enable compilation and when I did that I refresh the page and the fatal error message appeared. So I don t want the extension anymore if it is causing such problem. I have to launch my website and I need to find where is the error but i don t have the expertise in code editing php etc – Audrey DURAND Jan 6 '15 at 20:33
  • have you used any extension name like ConfigurableSwatches? – Amit Bera Jan 6 '15 at 20:37
  • I wanted to upload a extension for managing shipping rate tables and I don t even understand what configurable swatches is > I don use it and I don t want it. I prefer to remove all traces of the extension and have my website running again because I am anxious – Audrey DURAND Jan 6 '15 at 20:40
  • Can you access your Admin Panel? If yes, then disable the compiler again. Did you use FTP to upload the files? – ForMat Jan 6 '15 at 20:43
2

It looks like your code is loading disabled module. So, when Magento didn't find proper module by module name it'll try to load Mage_Modulename_...

I'd suggest to disable compilation at first, clean up your cache and check this problem out.

If it's happened again try to disable module in your uploaded extension. Find file of your module:

MAGEDIR/app/etc/modules/Your_Module.xml

replace

<active>true</active>

with

<active>false</active>

And clean up Magento cache.

MAGEDIR - it means path to root of Magento on your server.

  • I delete all the files of var/cache ? even if those files are called mage? I am sorry I am a neophyte in this domain and I could really use some help! – Audrey DURAND Jan 6 '15 at 20:47
  • :) Could you get a filename from the extension package in etc/module folder? Try to find the same file in the MagentoDIR/app/etc/modules folder. – Kirby Jan 6 '15 at 20:51
  • By the way, what is the name of the extension which you've uploaded? – Kirby Jan 6 '15 at 20:52
  • The name is Shipping Table rates by Amasty.But I don t want it anymore if it s to have those issues I can t handle myself. I payed 90 dollars for that and I have problems. So I removed the files of my cpanel but it didn t change the problem. I am desperate – Audrey DURAND Jan 6 '15 at 20:57
  • Ok, could find string "ConfigurableSwatches" in your Magento files and show the list? – Kirby Jan 6 '15 at 21:01
2

The class Mage_ConfigurableSwatches_Helper_Data was implemented in Magento 1.9.1.0

It appears that some extension or theme is calling that class and it's not present in your installation (due to a legacy version). Please check your Magento version to be sure it is at least 1.9.1.0.

If you have a previous version, be sure you have copied the patch files provided by the theme or extension vendor.

1

Below are multiple solutions:

  1. You need to create helper (Data.php) class is unavailable inside Mage_ConfigurableSwatches

    class Mage_ConfigurableSwatches_Helper_Data extends Mage_Core_Helper_Abstract
    {
    
    }
    

    And need to add in module config.xml file

    <global>
        <helpers>
            <configurableSwatches>
                <class>Mage_ConfigurableSwatches_Helper</class>
            </configurableSwatches>
        </helpers>
    </global>
    
  2. If you can't get into the admin interface but have SSH access you can disable it there with:

    php -f shell/compiler.php -- disable
    
    php -f shell/compiler.php -- clear
    
    php -f shell/compiler.php -- state
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.