5

I used memcached for sessions, but I got error for session_module_name

error is :

Warning: session_module_name(): Cannot find named PHP session module (memcache)  in /app/code/core/Mage/Core/Model/Session/Abstract/Varien.php on line 73

This is my local.xml

<session_save><![CDATA[memcache]]></session_save>
<session_save_path><![CDATA[tcp://127.0.0.1:11211?persistent=1&weight=2&timeout=10&retry_interval=10]]></session_save_path>

also this is my memcache result

[root@myserver]# ps ax | grep memcache
19669 ?        Ssl    0:37 memcached -d -p 11211 -u memcached -m 64 -c 5024 -P /var/run/memcached/memcached.pid -l 127.0.0.1
23788 pts/0    S+     0:00 grep memcache

and ports

[root@myserver]# netstat -tulpn | grep :11211
tcp        0      0 127.0.0.1:11211             0.0.0.0:*                   LISTEN      19669/memcached
udp        0      0 127.0.0.1:11211             0.0.0.0:*                               19669/memcached

what is wrong here for memcached configuration?

I can login and logout without problem, also telnet work as well and stats show me every thing!

closed as too broad by jharrison.au, Rajeev K Tomy, dh47, Keyul Shah, Matthias Zeis Jan 21 '15 at 5:36

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Do you use HHVM or usual php? – oleksii.svarychevskyi Jan 5 '15 at 15:22
  • Server is configured manual by myself and everything installed one by one! – sIiiS Jan 5 '15 at 15:26
  • 2
    Have you checked if php memcache module is installed? php -m | grep memcache – oleksii.svarychevskyi Jan 5 '15 at 15:29
  • Yup, result is memcache memcached – sIiiS Jan 5 '15 at 15:53
  • Console php and php cli can have different configuration. Could you put phpinfo() sumewhere? And check enabled modules. – oleksii.svarychevskyi Jan 5 '15 at 15:57