0

I get the following error message. I am new to Magento and this is my first install. Please help out. Thanks in advance. See detailed error message below.

There has been an error processing your request Exception printing is disabled by default for security reasons.

Error log record number: 858614085

a:5:{i:0;s:540:"Error in file: "/homepages/29/d527516279/htdocs/app/code/core/Mage/Tax/sql/tax_setup/install-1.6.0.0.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'tax_class' already exists, query was: CREATE TABLE `tax_class` (
  `class_id` smallint NOT NULL auto_increment COMMENT 'Class Id' ,
  `class_name` varchar(255) NOT NULL COMMENT 'Class Name' ,
  `class_type` varchar(8) NOT NULL default 'CUSTOMER' COMMENT 'Class Type' ,
  PRIMARY KEY (`class_id`)
) COMMENT='Tax Class' ENGINE=INNODB charset=utf8 COLLATE=utf8_general_ci";i:1;s:1008:"#0 /homepages/29/d527516279/htdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception('Mage_Core', 'Error in file: ...')
#1 /homepages/29/d527516279/htdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '1.6.0.4')
#2 /homepages/29/d527516279/htdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb('1.6.0.4')
#3 /homepages/29/d527516279/htdocs/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /homepages/29/d527516279/htdocs/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /homepages/29/d527516279/htdocs/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#6 /homepages/29/d527516279/htdocs/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#7 /homepages/29/d527516279/htdocs/index.php(87): Mage::run('', 'store')
#8 {main}";s:3:"url";s:10:"/index.php";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}
1

Please check for the table in your database

tax_class

If this exists try deleting it and run your installation. Seems like your database is pre-populated with some data which is causing you trouble

  • If my answer helped you then dont forget to upvote it. – Prashanta Jan 7 '15 at 2:43
0

Are you trying to attach installation to existing? , Just give new empty database name and give new database name during installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.