4

I changed my website admin panel url address from backend than my admin panel is lost.

Than change back all phpmyadmin settings:

admin/url/custom
web/unsecure/base_url
web/secure/base_url

This is my phpmyadmin screenshots, just I don't know why I have 2 web/unsecure/base_url and web/secure/base_url

enter image description here enter image description here enter image description here

and this is my app/etc/index.xml file

enter image description here

and I delete all my var/cache and var/session files from ftp.

I think look like I change back my all configuration, now when I try login my admin panel url 'admin', I have this error: There has been an error processing your request Exception printing is disabled by default for security reasons.

Error log record number: 570805581814

and this is 570805581814 report file:

a:5:{i:0;s:67:"Illegal scheme supplied, only alphanumeric characters are permitted";i:1;s:2908:"#0 /home/bilginirmak/public_html/app/code/core/Mage/Core/Model/Store.php(777): Zend_Uri::factory('admin/')
#1 /home/bilginirmak/public_html/app/code/core/Mage/Core/Model/Store.php(611): Mage_Core_Model_Store->isCurrentlySecure()
#2 /home/bilginirmak/public_html/app/Mage.php(382): Mage_Core_Model_Store->getBaseUrl('skin', NULL)
#3 /home/bilginirmak/public_html/app/code/core/Mage/Core/Model/Design/Package.php(349): Mage::getBaseUrl('skin', NULL)
#4 /home/bilginirmak/public_html/app/code/core/Mage/Core/Model/Design/Package.php(503): Mage_Core_Model_Design_Package->getSkinBaseUrl(Array)
#5 /home/bilginirmak/public_html/app/code/core/Mage/Core/Block/Abstract.php(1035): Mage_Core_Model_Design_Package->getSkinUrl('reset.css', Array)
#6 /home/bilginirmak/public_html/app/design/adminhtml/default/default/template/login.phtml(32): Mage_Core_Block_Abstract->getSkinUrl('reset.css')
#7 /home/bilginirmak/public_html/app/code/core/Mage/Core/Block/Template.php(241): include('/home/bilginirm...')
#8 /home/bilginirmak/public_html/app/code/core/Mage/Core/Block/Template.php(272): Mage_Core_Block_Template->fetchView('adminhtml/defau...')
#9 /home/bilginirmak/public_html/app/code/core/Mage/Core/Block/Template.php(286): Mage_Core_Block_Template->renderView()
#10 /home/bilginirmak/public_html/app/code/core/Mage/Adminhtml/Block/Template.php(81): Mage_Core_Block_Template->_toHtml()
#11 /home/bilginirmak/public_html/app/code/core/Mage/Core/Block/Abstract.php(919): Mage_Adminhtml_Block_Template->_toHtml()
#12 /home/bilginirmak/public_html/app/code/core/Mage/Core/Block/Text/List.php(43): Mage_Core_Block_Abstract->toHtml()
#13 /home/bilginirmak/public_html/app/code/core/Mage/Core/Block/Abstract.php(919): Mage_Core_Block_Text_List->_toHtml()
#14 /home/bilginirmak/public_html/app/code/core/Mage/Core/Model/Layout.php(555): Mage_Core_Block_Abstract->toHtml()
#15 /home/bilginirmak/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(390): Mage_Core_Model_Layout->getOutput()
#16 /home/bilginirmak/public_html/app/code/core/Mage/Adminhtml/controllers/IndexController.php(82): Mage_Core_Controller_Varien_Action->renderLayout()
#17 /home/bilginirmak/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_IndexController->loginAction()
#18 /home/bilginirmak/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('login')
#19 /home/bilginirmak/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#20 /home/bilginirmak/public_html/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
#21 /home/bilginirmak/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#22 /home/bilginirmak/public_html/index.php(87): Mage::run('', 'store')
#23 {main}";s:3:"url";s:6:"/admin";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:5:"admin";}

So guys what I have to do for get back my admin panel?

2

As far as I am aware you do not need to specify the admin path in the database simply in the local.xml.

In the database you should have the general website url under the path web/secure/base_url and web/unsecure/base_url and then under your local.xml you can set the admin frontName. Once these are set you can remove the other items and this should work.

1

Try to change your store "stores = > web/secure/base_url" and "stores = > web/unsecure/base_url" to your full url or delete them completely after taking a backup of the table.

  • I changed "stores = > web/secure/base_url" and "stores = > web/unsecure/base_url" AND IT'S WORKING NOW =)) thank you prashanta!!!!!!! – bilgin Dec 30 '14 at 5:56
1

Just had the same problem after I changed "Admin Base URL" on the website www.bimproject.net. Normally you should never use that option but change local.xml instead.

I have deleted 3 records that in your example point to "/admin": one for secure URL, another for non secure, third one just keeps current configured value. After that my backend started to work again. You may also need to clean the cache.

You had two web/unsecure/base_url and web/secure/base_url records because one pair of records are default values for all stores (including frontend) and another two were created for admin store.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.