2

I have a site with Magento installed. It is installed in a subdirectory (http://mysite.com/store) -- Everything works properly, except for when I go to a page that should 404 (ex: http://mysite.com/store/dfgsdfg). I would expect this to show the page defined in my Magento Default No-route URL, but instead it is showing the default apache 404 page (Not Found The requested URL /index.php was not found on this server. Apache/2.4.6 (Ubuntu) Server at www.vosslighting.com Port 80)

In my .htaccess file I have (just the pertinent parts):

DirectoryIndex index.php
Options +FollowSymLinks
RewriteEngine on
RewriteRule .* index.php [L]

I have the line '#RewriteBase /store/' commented out, but it doesn't seem to help anything when I uncomment it.

Can anyone point me in the right direction of where I might need to look to get my custom 404 pages?

  • Is Mod Rewrite enabled and working properly for your server? You may also want to try replacing your .htaccess file with the default Magento .htaccess if you haven't tried it yet. – Aspiration Hosting Dec 25 '14 at 15:52
  • Mod Rewrite is enabled and working, everything is redirecting to index.php as expected. The site is working perfectly fine, the only thing not working is the 404 pages. – James Pelton Dec 26 '14 at 22:36
  • 1
    Magento's many 404 pages – Fiasco Labs May 3 '15 at 20:06
0

I finally figured out what the problem was. In my virtual host, I had ProxyErrorOverride On set. This was causing my proxy to handle 404 headers instead of Magento

-1

it changing the .htaccess file line:

RewriteBase /store/magento/

Put your path relative to magento root

or follow this article

http://www.inmotionhosting.com/support/website/how-to/setting-a-404-error-page-via-htaccess

  • Thanks for the suggestion, Adding RewriteBase /store/ didn't help anything though. – James Pelton Dec 24 '14 at 14:41
  • And I would prefer to not hack around Magento's 404 pages with a custom apache 404 page. I would rather use the 404 system Magento has in place and just get it to work properly. – James Pelton Dec 24 '14 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.