0

I have MAMP & MAMP PRO.

I tried to install Magento 2 beta. When i write "composer install" the system returns me this error:

Your requirements could not be resolved to an installable set of packages.

Problem 1 - The requested PHP extension ext-mcrypt * is missing from your system.

I have check the services of system and mcrypt is enabled.

How i can solve?

Thanks

closed as off-topic by Keyul Shah, Marius Dec 21 '14 at 6:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Marius
If this question can be reworded to fit the rules in the help center, please edit the question.

  • enable the mcrypt php extension – Marius Dec 20 '14 at 18:06
  • as I said just above, the extension mcrypt is active – Antonio Carboni Dec 20 '14 at 18:12
  • If composer says it's not, then it's not. Maybe you have 2 php versions. – Marius Dec 20 '14 at 18:19
  • I have the same problem too, the problem is magenta is using macOS's php instead of php install on MAMP – wlin Dec 20 '14 at 18:26
  • it is probable, but how do I do recognize a composer the php of MAMP? – Antonio Carboni Dec 20 '14 at 18:27
3

Create a file called .bash_profile on your home directory (if you don't have this file already), and add this to the file:

export PATH=/Applications/mamp/bin/!YOUR-PHP-VERSION!/bin:$PATH

@ https://stackoverflow.com/questions/10857068/change-the-php-path-to-mamps-php

  • make sure you fill in your php version, you can get this info at phpinfo on mamp start page. – wlin Dec 20 '14 at 18:29
  • if you are still running in to some problem, try change the php version on mama's version in the preference, – wlin Dec 20 '14 at 18:31
  • I am using 1.6.2 and it works fine for me. – wlin Dec 20 '14 at 18:32
  • The easiest approach I found was to add a symlink of current PHP into /usr/local/bin/php in this way I'm forcing composer to use the php i need. – obsergiu Feb 12 at 10:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.