2

This question already has an answer here:

Have recently upgraded to Magento 1.9.1.0 and now when you go through checkout and enter your details and password, it popups with an error saying - Please make sure passwords match.

I have tried over and over again and cannot get it working.

marked as duplicate by Simon, Fabian Blechschmidt, David Manners, Amit Bera, Moose Feb 24 '15 at 9:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

also try this

Change this code

app\code\core\Mage\Customer\Model\Customer.php
$confirmation = $this->getPasswordConfirmation();

to this code

$confirmation = $this->getConfirmation();
  • 1
    I have change the code as per your suggestion and now the checkout works great, however, now when you try to register for just an account it comes up with 'Please make sure passwords match.' – Cruzier Dec 20 '14 at 14:56
  • same here have the same problem – open-ecommerce.org Sep 16 '15 at 18:29
1

it's because of this change in 1.9.1 update. You have to update your extensions code -Customer passwords are no longer stored in clear text during registration.

I would suggest to check if these exist as attributes.

Under Catalog->Attributes->Manage Attributes check if they exist as attributes called Storeowner or Storetype.

Then you will need to either remove them if applicable or just set them to not required under Properties->Values Required = No.

  • I have checked attributes and neither of those attributes present. – Cruzier Dec 20 '14 at 14:55
1

If like @cruzier your "my account" still doesnt work after the above changes make sure you either disable compilation or re-compile in admin under system|tools|compilation.

  • Hi there, this did not work for me neither. Still have not found a solution :( – Cruzier Jan 9 '15 at 18:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.