3

I hope someone can help me. I'm using Magento 1.9.1.0. Since yesterday my customers get no order confirmation by email. In the log file I get the following error message,

exception 'Zend_Mail_Exception' with message 'Subject set twice' in /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/lib/Zend/Mail.php:933 Stack trace:

0 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/community/Mage/Smtp/Model/Email/Template.php(40): Zend_Mail->setSubject('Laseria's Gesch...')

1 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Core/Model/Email/Template.php(508): Mage_Smtp_Model_Email_Template->send(Array, Array, Array)

2 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Core/Model/Email/Template/Mailer.php(84): Mage_Core_Model_Email_Template->sendTransactional('11', 'general', Array, Array, Array, '1')

3 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Sales/Model/Order.php(1354): Mage_Core_Model_Email_Template_Mailer->send()

4 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Sales/Model/Order.php(1369): Mage_Sales_Model_Order->queueNewOrderEmail(true)

5 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Adminhtml/controllers/Sales/OrderController.php(139): Mage_Sales_Model_Order->sendNewOrderEmail()

6 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Core/Controller/Varien/Action.php(418): Mage_Adminhtml_Sales_OrderController->emailAction()

7 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('email')

8 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Core/Controller/Varien/Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))

9 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/code/core/Mage/Core/Model/App.php(354): Mage_Core_Controller_Varien_Front->dispatch()

10 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/app/Mage.php(684): Mage_Core_Model_App->run(Array)

11 /is/htdocs/wp10917496_PXDL7M6OYT/www/magento/index.php(87): Mage::run('', 'store')

12 {main}

Thanks in advance

closed as too broad by Keyul Shah, brentwpeterson, Mufaddal, Fabian Blechschmidt, Moose Dec 18 '14 at 11:11

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Did you edit an e-mail template lately? Maybe you duplicated the subject line. – Marius Dec 18 '14 at 12:26
  • post the code that calls the email template and set its fields. – Manikandan Arunachalam Dec 18 '14 at 12:39

Browse other questions tagged or ask your own question.