2

Magento 1.9.0.1 CE on LAMP

Experiencing an issue with the customer login page on our website. Users of IE7 - IE11 only are experiencing a redirect loop - the page refreshes without error message of any sort after typing in credentials and clicking "login". I'm not seeing any Javascript or server errors related to it. My server access log seems to be showing the same login URLs as when Chrome and Safari try to use customer login. The real problem I feel is happening is in how my site issues session or cookies. I'm 99% certain that it is relevant to that and not related to any other common problem like "form key".

Here are my cookie settings:

Cookie Lifetime: 86400
Cookie Path: /
Cooke Domain: .mydomain.com
Use HTTP Only: No
Cookie Restriction Mode: No

"mydomain" is actually replaced with our actual domain on the site.

Could any of these settings be affecting IE?

2

Did a clean install of CE 1.9.1 and noticed the following default settings:

Cookie Lifetime: 3600
Cookie Path: 
Cooke Domain: 
Use HTTP Only: Yes
Cookie Restriction Mode: No

So I modified my settings to mimic that by dropping Cookie Path, Cookie Domain and set HTTP Only to Yes:

Cookie Lifetime: 86400
Cookie Path: 
Cooke Domain: 
Use HTTP Only: Yes
Cookie Restriction Mode: No

All IE versions on all variations of Windows tested and confirmed. Also tested other browsers to confirm no adverse side-effect. Works perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.