2

Add SOLR category refinement to cms page (which already include a widget that displays new products).

Is it possible to do this? If so, how? I know you can't use php code within cms pages. any directional attack vector suggestions would be appreciated.

  • there are information missing. 1. Do you use the enterprise edition? 2. if not, what do you use to add SOLR? Do you already know how to add a widget to a cms page? – Flyingmana Dec 21 '14 at 12:39
  • @Flyingmana I have enterprise edition, as it says in the header. And yea, I know how to add a widget.. but some clarification would be nice. – easymoden00b Dec 22 '14 at 13:05
  • magento.stackexchange.com/questions/35720/… You should be able to simply add the layered nav to the CMS page XML Layout, Solrs refinement or fauceted search overrides Magento's built-in one when Solr is enabled & Enable Solr Engine for Catalog Navigation. <reference name="left"><block type="enterprise_search/catalog_layer_view" name="catalog.leftnav" before="-" template="catalog/layer/view.phtml"/></reference> – B00MER Dec 22 '14 at 19:39
  • 1
    @B00MER I dont really understand, care to expound upon your comment in an answer? – easymoden00b Dec 22 '14 at 21:16
1
+50

CMS > Pages > Manage content.

Page Information tabs > Design > Layout Update XML

<reference name="left">
  <block type="enterprise_search/catalog_layer_view" name="catalog.leftnav" before="-" template="catalog/layer/view.phtml"/>
</reference>

Just ensure you are referencing the block of the Layout, this XML snippet would work for 2 columns with left bar and 3 columns layouts.

Hope that helps

| improve this answer | |
  • Okay, I copied the above onto the CMS page's Layout Update XMLs section (with a 2 column with left bar configuation) and after saving it doesn't seem to show anything different in the CMS page preview. – easymoden00b Dec 23 '14 at 19:16
  • CMS Preview may not show it properly, just content of the page, try saving and make sure to clear cache just in case. Tested this with 1.13.1.x EE. – B00MER Dec 23 '14 at 19:21
  • The CMS preview takes you to the resolved url (if not, regardless, I manually entered the url). Flushed the cache, still no sidebar. Did you just have a blank cms page with a sidebar? or anything else in the contents? – easymoden00b Dec 23 '14 at 19:27
  • new install of 1.13.1.x, just took an existing out of box page, customer service, switched the layout to 2 column with left bar, pasted XML, saved and Shop By appears. – B00MER Dec 23 '14 at 19:33
  • Strange, I give my css page a custom theme (change it to 'default') and the sidebar appaears. In my theme, no dice. – easymoden00b Dec 23 '14 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.