0

I tried to install Magento2 on Windows which runs PHP 5.5.19 and MySQL 5.6.X versions (from xampp package) through Composer, but I received the following errors after running composer install (please check here). UPDATE 1

https://github.com/magento/magento2/issues/813

UPDATE 2 - Issue Raw

Loading composer repositories with package information
Installing dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package php could not be found in any version, there may be
a typo in the package name.
  Problem 2
    - The requested package php could not be found in any version, there may be
a typo in the package name.
  Problem 3
    - Installation request for zendframework/zend-stdlib 2.3.1 -> satisfiable by
 zendframework/zend-stdlib[2.3.1].
    - zendframework/zend-stdlib 2.3.1 requires php >=5.3.23 -> no matching packa
ge found.
  Problem 4
    - Installation request for zendframework/zend-code 2.3.1 -> satisfiable by z
endframework/zend-code[2.3.1].
    - zendframework/zend-code 2.3.1 requires php >=5.3.23 -> no matching package
 found.
  Problem 5
    - Installation request for zendframework/zend-server 2.3.1 -> satisfiable by
 zendframework/zend-server[2.3.1].
    - zendframework/zend-server 2.3.1 requires php >=5.3.23 -> no matching packa
ge found.
  Problem 6
    - Installation request for zendframework/zend-soap 2.3.1 -> satisfiable by z
endframework/zend-soap[2.3.1].
    - zendframework/zend-soap 2.3.1 requires php >=5.3.23 -> no matching package
 found.
  Problem 7
    - Installation request for zendframework/zend-uri 2.3.1 -> satisfiable by ze
ndframework/zend-uri[2.3.1].
    - zendframework/zend-uri 2.3.1 requires php >=5.3.23 -> no matching package
found.
  Problem 8
    - Installation request for zendframework/zend-validator 2.3.1 -> satisfiable
 by zendframework/zend-validator[2.3.1].
    - zendframework/zend-validator 2.3.1 requires php >=5.3.23 -> no matching pa
ckage found.
  Problem 9
    - Installation request for zendframework/zend-console 2.3.1 -> satisfiable b
y zendframework/zend-console[2.3.1].
    - zendframework/zend-console 2.3.1 requires php >=5.3.23 -> no matching pack
age found.
  Problem 10
    - Installation request for zendframework/zend-modulemanager 2.3.1 -> satisfi
able by zendframework/zend-modulemanager[2.3.1].
    - zendframework/zend-modulemanager 2.3.1 requires php >=5.3.23 -> no matchin
g package found.
  Problem 11
    - Installation request for zendframework/zend-mvc 2.3.1 -> satisfiable by ze
ndframework/zend-mvc[2.3.1].
    - zendframework/zend-mvc 2.3.1 requires php >=5.3.23 -> no matching package
found.
  Problem 12
    - Installation request for zendframework/zend-text 2.3.1 -> satisfiable by z
endframework/zend-text[2.3.1].
    - zendframework/zend-text 2.3.1 requires php >=5.3.23 -> no matching package
 found.
  Problem 13
    - Installation request for zendframework/zend-eventmanager 2.3.1 -> satisfia
ble by zendframework/zend-eventmanager[2.3.1].
    - zendframework/zend-eventmanager 2.3.1 requires php >=5.3.23 -> no matching
 package found.
  Problem 14
    - Installation request for zendframework/zend-view 2.3.1 -> satisfiable by z
endframework/zend-view[2.3.1].
    - zendframework/zend-view 2.3.1 requires php >=5.3.23 -> no matching package
 found.
  Problem 15
    - Installation request for zendframework/zend-servicemanager 2.3.1 -> satisf
iable by zendframework/zend-servicemanager[2.3.1].
    - zendframework/zend-servicemanager 2.3.1 requires php >=5.3.23 -> no matchi
ng package found.
  Problem 16
    - Installation request for zendframework/zend-json 2.3.1 -> satisfiable by z
endframework/zend-json[2.3.1].
    - zendframework/zend-json 2.3.1 requires php >=5.3.23 -> no matching package
 found.
  Problem 17
    - Installation request for zendframework/zend-config 2.3.1 -> satisfiable by
 zendframework/zend-config[2.3.1].
    - zendframework/zend-config 2.3.1 requires php >=5.3.23 -> no matching packa
ge found.
  Problem 18
    - Installation request for zendframework/zend-form 2.3.1 -> satisfiable by z
endframework/zend-form[2.3.1].
    - zendframework/zend-form 2.3.1 requires php >=5.3.23 -> no matching package
 found.
  Problem 19
    - Installation request for zendframework/zend-di 2.3.1 -> satisfiable by zen
dframework/zend-di[2.3.1].
    - zendframework/zend-di 2.3.1 requires php >=5.3.23 -> no matching package f
ound.
  Problem 20
    - Installation request for zendframework/zend-serializer 2.3.1 -> satisfiabl
e by zendframework/zend-serializer[2.3.1].
    - zendframework/zend-serializer 2.3.1 requires php >=5.3.23 -> no matching p
ackage found.
  Problem 21
    - Installation request for zendframework/zend-log 2.3.1 -> satisfiable by ze
ndframework/zend-log[2.3.1].
    - zendframework/zend-log 2.3.1 requires php >=5.3.23 -> no matching package
found.
  Problem 22
    - Installation request for zendframework/zend-http 2.3.1 -> satisfiable by z
endframework/zend-http[2.3.1].
    - zendframework/zend-http 2.3.1 requires php >=5.3.23 -> no matching package
 found.
  Problem 23
    - Installation request for magento/zendframework1 1.12.9 -> satisfiable by m
agento/zendframework1[1.12.9].
    - magento/zendframework1 1.12.9 requires php >=5.2.11 -> no matching package
 found.
  Problem 24
    - Installation request for composer/composer 1.0.0-alpha8 -> satisfiable by
composer/composer[1.0.0-alpha8].
    - composer/composer 1.0.0-alpha8 requires php >=5.3.2 -> no matching package
 found.
  Problem 25
    - Installation request for phpunit/phpunit 4.1.0 -> satisfiable by phpunit/p
hpunit[4.1.0].
    - phpunit/phpunit 4.1.0 requires php >=5.3.3 -> no matching package found.
  Problem 26
    - Installation request for squizlabs/php_codesniffer 1.5.3 -> satisfiable by
 squizlabs/php_codesniffer[1.5.3].
    - squizlabs/php_codesniffer 1.5.3 requires php >=5.1.2 -> no matching packag
e found.
  Problem 27
    - phpmd/phpmd 2.1.3 requires php >=5.3.0 -> no matching package found.
    - phpmd/phpmd 2.1.2 requires php >=5.3.0 -> no matching package found.
    - phpmd/phpmd 2.1.1 requires php >=5.3.0 -> no matching package found.
    - phpmd/phpmd 2.0.0 requires php >=5.3.0 -> no matching package found.
    - phpmd/phpmd 1.5.1 requires php >=5.3.0 -> no matching package found.
    - phpmd/phpmd 1.5.0 requires php >=5.3.0 -> no matching package found.
    - phpmd/phpmd 1.4.1 requires php >=5.3.0 -> no matching package found.
    - phpmd/phpmd 1.4.0 requires php >=5.3.0 -> no matching package found.
    - Installation request for phpmd/phpmd @stable -> satisfiable by phpmd/phpmd
[1.4.0, 1.4.1, 1.5.0, 1.5.1, 2.0.0, 2.1.1, 2.1.2, 2.1.3].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your min
imum-stability setting
   see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> f
or more details.

Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common
 problems.
  • above 'click here' link shows blank page.. Is this still issue?? – Pavan Kumar Dec 18 '14 at 5:18
  • @PavanKumar Kindly check this link pastebin.com/WSWrKPif also added the raw copy of the issue. – Haijerome Dec 18 '14 at 5:51
4

Either of the approaches given below solve the issue, its up to you to pick one

Recommended

Edit the composer.json file as shown below:

"php": "~5.4.11|~5.5.0|~5.6.0", 

Not much recommended - but its certainly let the magento pre-installation (downloading required vendor packages) begin

composer install --ignore-platform-reqs 

PS: Credits to Vlad Veselov and nyov

  • At that time php 5.6 was not officially supported. It's likely to be added soon - we want to Add it to test automation before claiming support. – Alan Kent Jan 1 '15 at 19:03
0

Make sure you have latest version of XAMPP installed in windows which has PHP version 5.6.3
If you are using Magento2 version 0.42.0-beta2 or later one you need to make following changes in composer.json file on line number 11.

"php": "~5.4.11|~5.5.0|~5.6.0",

In case if you are updating Magento2 from any old release then this changes is also required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.