3

I'm hoping you all could help me with a troubling issue. It seems that certain orders are not being received by the Magento backend for certain customers. They receive a confirmation email, yet on our Admin backend there is no record of the order.

The strangest part is that their order is out of sync with our order numbers. While orders normally go upwards in chronological order (we're currently on 100001273) - the orders not on record are totally out of sync with where we are now (ex. one of the customer's emails showed 100000301 as their order number)

Looks like the store is running on Magento 1.5.1.0.

Any help is tremendously appreciated. Thank you!

5
  • 1
    Honestly this is technically just not possible. Could it be there is another store running? A development or staging area perhaps... Or are old orders reprocessed by, for example, the payment service provider – Sander Mangel Dec 17 '14 at 14:38
  • @SanderMangel We are currently redesigning our site and do have a development site, as well as have made a copy of the current site on new hosting. Could either of these be the culprit? – Jonathan Dec 17 '14 at 14:53
  • I would check both backends for those orders. Next to that always make sure to set the robots under Sys > Conf > Design to noindex/nofollow, turn on the demo notixe and optionally put an IP block in your .htaccess file – Sander Mangel Dec 17 '14 at 14:56
  • It is possible for a customer to attempt to checkout and fail, and then come along later and successfully checkout - and they would then have an out-of-sync increment ID. However, it seems more likely that its come from the staging or test sites. – Douglas Radburn Dec 17 '14 at 15:16
  • Can you look at the headers from the email to double check which server the emails are coming from? – Douglas Radburn Dec 17 '14 at 15:18
1

You probably have an error during the order save process, which causes a rollback of the transaction, but does not rise an php error, which causes the mail after the orderSave to get sent.

The order number is not really a problem, they already get reserved in the quote, and normally can be out of order (but dont appear so, as the admin area sorts them correct)

you should check your logs (also the php ones) for possible errors or notices, also check the config of your error reporting

0

Sounds like the site is pointing to the wrong database. If you are running development/test sandboxes maybe the local.xml got carried over to the production site?

Check your app/etc/local.xml is pointing to the correct database.

Another possible explanation for the wrong database could be multiple .xml files in the app/etc directory. I discovered, quite to my frustration, that the .xml files are processed in alphabetical order, so something like sandbox.local.xml in that directory could override local.xml settings.

See: Why is Magento picking up the wrong database settings from the wrong file in app/etc?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.