2

My Magento shop has the Dutch Tax settings, but I cannot get them to work. I have enabled all the right settings but it will not make any tax changes.

When I add a product to the cart it displays:

No TAX.

In the backend I give the product a 21% tax rate with it, and the tax settings are as followed:

Information of shipping

Has anybody any clue what i am doing wrong? I have been searching through scripts but didn't edit anything. Please help, cant launch now.

TAX RATES

tax rates Tax rates 2 enter image description here

11
  • Can you share a screenshot of your tax rates that you setup? Also, did you enable the product as a taxable product? If so, which option did you choose? – kab8609 Dec 15 '14 at 17:36
  • @kab8609 see the 2 below images. Is that what you mean? And where do i enable that? In the product creation itself? I give it a price and then a tax class 21% with it. – Axel Dekker Dec 15 '14 at 17:48
  • When you go into a product to manage it, you should see it in the price section: dropbox.com/s/17xyn38iqmt01dv/… – kab8609 Dec 15 '14 at 17:57
  • @kab8609 yes i use there the 21% Omzetbelasting (dutch for tax) for the product. That is what is set-up out of my settings i imported for dutch tax. – Axel Dekker Dec 15 '14 at 18:02
  • You didn't answer my question at all. Is the tax class "None", "Taxable Goods", or "Shipping" on the product? Also, did you go through the checkout process? Since this is a region, it might not know you are in the Netherlands until you go through the checkout process. – kab8609 Dec 15 '14 at 18:04
1

You will also need to ensure the tax class for each product is set correctly.

In your individual products ensure that under General tab that Tax Class is set to Taxable Goods.

You can also do this in bulk by multiselecting all products that don't have Tax Class set correctly and then on the actions drop down select 'Update Attributes' and set as above.

1

I see your tax calculation is based on shipping origin. If I were to guess: your origin (it's a little below these settings in System Configuration Tax) is still on US. Change that to Netherlands (put * in the rest of the fields) and you should be golden.

1
  • This was already posted like that... Netherlands, and shipping origin were already like that. – Axel Dekker Dec 22 '14 at 18:08
1

Problem has been solved. I did not use Taxable goods as title of the attribuut. It changed when i made a tax class with names taxable goods and rate 21%!

How do you set a question to answered on here?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.