0

I've an urgent issue that I don't know how to troubleshoot. I'd be grateful for some suggestions.

When I change the price for a particular product in the backend, it doesn't change on the frontend. I've done the usual reindex and clear cache - but no go.

edit: I've cleaned this question up, removing a lot of additional issues which may have been a distraction. Further troublshooting of this issue gives the following updates:

  • refreshed caches, and restarted apache - no change
  • creating a new simple product in the backend, then changing that - does work!

I use MAGMI to make my updates to products, adding them, changing prices etc, so perhaps this is the problem. Somehow, the Magmi process has 'broken' the products somehow.

Does anyone have ideas on how I can troubleshoot that further, and somehow fix? The products look fine in the admin screen - they just can't be updated on the front end.

(If I make the update via Magmi, it works though)

  • 1
    It is either Cache, Index or a combination of the both. Try restarting Apache – brentwpeterson Dec 11 '14 at 17:09
  • unfortunately, that didn't help – egg Jan 17 '15 at 16:32
1

Brents answer is a good start, would like to add. Some processes I usually follow when things seem to stop working.

  1. Check the Magento Log Files for any errors

  2. Check the apache error log files.

Brendan

  • Thanks. I will check the logs. However in the meantime, I was able to force the change by uploading the prices via MAGMI. I will close the question for now then! – egg Dec 12 '14 at 8:04
0

As a workaround, I was able to force the change by uploading the prices via MAGMI.

My problems continue - so I will update the question with additional details.

  • Recommend to update new info on your question instead add answer Hope it fix! – Moon Jan 17 '15 at 16:41
  • thanks - indeed, I've cleaned up the question, and added the latest status. – egg Jan 17 '15 at 16:47
0

update: I noticed that I didn't use MAGMI_IGNORE correctly on every field. Having recreated the Magmi import file (hopefully correctly this time) things seem to be working better!!

So for others that might find this post, if you use Magmi for multi language sites, do take care that you only ask Magmi to update the fields needed for the second language, and use MAGMI_IGNORE for the things which it can skip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.