7

I don't want out of stock products to be appeared in my magento website. I have done the following to ensure I don't see my configurable product in the frontend.

Configurable product inventory - out of stock
Associated products inventory - out of stock, qty - 0
config settings -> quantity to become out of stock - 0
config settings -> display out of stock items - No
config settings -> backorder - No

Inspite of all these settings, I just see "Add to cart" being disabled for this product. But the product still appears in the site when I access it via URL. I don't want this product to be seen in my website anymore by whatever means it may be.

Is showing product without "add to cart" magento default when it means "display out of stock products - No"?

Please clarify this setting? And how should I remove this product from my website using magento default settings? (I don't want the product to be disabled in backend, just hide in frontend). Thanks.

  • 1
    Did you clear all the caches and reindex? – Sander Mangel Dec 11 '14 at 8:56
  • Is this the case with all caching disabled? Any different settings in the above at different configuration scopes? – Jonathan Hussey Dec 11 '14 at 9:22
  • Hi Sander, Cache is disabled and I have also reindexed all the available indexes. Thanks. – UdaySagar Dec 11 '14 at 9:54
  • Hi Hussey, Yes, cache is disabled. Hmm, all the settings that I shown in the question exactly match what I have set in my admin panel.Thanks. – UdaySagar Dec 11 '14 at 9:55
14

This is actually a feature of Magento.
Setting Display out of stock products to No only hides them from the category list pages and the search results page.
The product page is actually still available.
Starting with CE 1.9.1 there is even a message under the config setting Display out of stock products saying Products will still be shown by direct product URLs..
And this is actually a good thing.
This way search engines don't register a lot of 404 pages when your products get out of stock.
I don't see the harm in leaving it like that. The customer cannot order them anyway.
If you want a product not to be available at all in your store you have to mark it as disabled or set it's visibility to Not visible individually or remove its association to the websites from the websites tab on the admin product edit page.

| improve this answer | |
1

is this a problem with all products, or only with the products that are marked as "new"? If this problem only appears for "new" products, you can solve it when you go to the product page > Autosettings > "Set product as New from date / to date - erase both dates.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.