2

I have 2 separate installations of Magento in different sub-domains on the same host.

The first one, my development store where I test upgrades, try out new add-ons etc. upgraded from 1.8.1 to 1.9.1 just fine (I used the upgrade in Magento Connect) apart from a couple of minor colour issues in a 3rd party template which were easily fixed.

I have just tried to upgrade the live store using exactly the same method and it crashed out part way through (got a cache flushing error in the Magento Connect console) and now I am getting an invalid PHP version error (says I need PHP 5.3.0 or newer). I have run phpinfo and I am getting 5.2.6 as the installed version.

This makes no sense at all, as the test store is running just fine with 5.2.6.

Anyone have any ideas?

  • You have confirmed you are running the exact same version of PHP on your dev server? – brentwpeterson Dec 10 '14 at 13:01
  • The two installations are on the same server; it is shared hosting with a commercial host. – PeteW1959 Dec 10 '14 at 13:34
2

The system requirements for version 1.9 are PHP5.4 or 5.5 You will have to update you current server to the newer version of PHP. In addition you will get a performance boost by going with PHP5.4 or higher

SYSTEM REQUIREMENTS FOR MAGENTO ENTERPRISE EDITION 1.14.1 AND COMMUNITY EDITION 1.9.1

Magento requires a LAMP or LNMP stack

Operating System Linux x86-64

Web Server Apache 2.x Nginx 1.7.x

Database MySQL 5.6 (Oracle or Percona)

PHP PHP 5.4 PHP 5.5

SSL A valid security certificate is required for HTTPS. Self-signed SSL certificates are not supported. SUPPORTED TECHNOLOGIES

Redis REDIS can be used for session or cache storage

Memcached Memcached can be used for session or cache storage (EE Only)

Apache Solr SOLR SEARCH can be used as a search provider

http://magento.com/resources/system-requirements

  • The two installations are on the same server, so I don't understand how the dev installation is working. I can't upgrade PHP as it is on commercial shared hosting. – PeteW1959 Dec 10 '14 at 13:34
  • I'm curious why there is a discrepancy between the requirements listed on magento.com and the requirements checked in index.php. If 5.4 is required for 1.9, why does index.php check for versions less than 5.3.0? – pspahn Jan 8 '15 at 19:25
1

the php version compare happens in the index.php, its very likely that it got changed, or not updated before.

Also, you run a very outdated version of php. There are a lot of security fixes, which were not backported to php 5.3 or even 5.2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.