We upgraded to CE from and now the new order confirmation emails have stopped sending.

I have checked the cronjob (.php) on our server and changed it to run every minute instead of five but the emails are still not sending.

I have set up a .sh cronjob and this has not solved the problem either.


  • The cronjob isnt the issue. If you login via SSH to your server, try doing a grep to see if you can see if your email made it to the server level. Please note, you may have your maillog in another spot and will need to correct it. "cat /var/log/maillog | grep youremail@thatyouresendingto.com" – kab8609 Dec 5 '14 at 17:25
  • Related: magento.stackexchange.com/questions/46063/… – pspahn Dec 5 '14 at 17:25
  • Ok, I've read the post on the link and tried the edit out line option./** ->setQueue($this->getQueue()) */ and this has worked. If I go back into an order and resend the email it now sends. Surely this isn't a good way to correct this. This is a fundemental part of the system being able to send email to confirm an order. What's the cause? – Edge Sports Dec 5 '14 at 18:53
  • Going to close this as a duplicate given the excellent support thread at the referenced question. That said feel free to request a reopen if you feel this is truly distinct. – benmarks Feb 15 '15 at 16:08