2

I have created a custom language file for a feature that I have built into our Magento website. The language variables work fine on my local machine (of course), however on our staging environment it doesn't. My local machine is Windows and staging server is Linux, so obvious answer would be an issue with filename casing, but imho these are right.

I have my own block that overwrites the Mage_Catalog, called Feno_Catalog which works fine. To that config.xml file I've appended some code to load the Feno_Catalog.csv;

/local/Feno/Catalog/etc/config.xml:

<?xml version="1.0" encoding="iso-8859-1"?>
<config>
    <modules>
        <Feno_Catalog>
            <version>0.1.0</version>
        </Feno_Catalog>
    </modules>
    <global>
        <blocks>
            <catalog>
                <rewrite>
                    <class>Feno_Catalog_Block</class>
                </rewrite>
            </catalog>
        </blocks>
        <helpers>
            <catalog>
                <rewrite>
                    <class>Feno_Catalog_Helper</class>
                </rewrite>
            </catalog>
        </helpers>
    </global>
    <frontend>
        <translate>
            <modules>
                <Feno_Catalog>
                    <files>
                        <default>Feno_Catalog.csv</default>
                    </files>
                </Feno_Catalog>
            </modules>
        </translate>
    </frontend>
    <adminhtml>
        <translate>
            <modules>
                <Feno_Catalog>
                    <files>
                        <default>Feno_Catalog.csv</default>
                    </files>
                </Feno_Catalog>
            </modules>
        </translate>
    </adminhtml>
</config>

The CSV file has been put into 2 folders: /app/locale/[de_DE|en_US]/ with matching casing.

As I mentioned it works fine on my local machine, but not on the staging server. What could cause this? I've searched for quite a bit and cleared cache (although cache is turned off), switched languages (both languages don't work - The language keys are like "poll_question_a1").

When I move the translations to Mage_Catalog.csv everything also works fine (but of course that is not what I want).

So how to fix? Is there any way to find the cause of this?

closed as off-topic by Flyingmana, Keyul Shah, brentwpeterson, Marius Jan 27 '15 at 19:21

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Flyingmana, Keyul Shah, brentwpeterson, Marius
If this question can be reworded to fit the rules in the help center, please edit the question.

  • By any chance you have developer mode enabled on your local machine or on the staging server? – Marius Dec 4 '14 at 12:58
  • Developer mode is currently disabled on both environments. I tried switching it on but it breaks on some other warning. Anything specific I need to look for? – Richard Dec 4 '14 at 13:03
  • I found this if (Mage::getIsDeveloperMode()) { unset($this->_data[$key]); } in the translate model and I thought it might have something to do with it. – Marius Dec 4 '14 at 13:05
  • Unfortunately not, added a die("in dev mode"); inside the statement, but no change. – Richard Dec 4 '14 at 13:16
  • This is a long shot, but have you tried removing encoding="iso-8859-1" from the config.xml file? – ForMat Dec 4 '14 at 13:40