0

This is my website (www.4happydays.com)

yesterday till noon it was working properly. but after that i got this error...

Error in file: "/home/happydays/public_html/app/code/core/Mage/Core/sql/core_setup/install-1.6.0.0.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'core_resource' already exists

Trace:
#0 /home/happydays/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception('Mage_Core', 'Error in file: ...')
#1 /home/happydays/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '1.6.0.4')
#2 /home/happydays/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb('1.6.0.4')
#3 /home/happydays/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/happydays/public_html/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/happydays/public_html/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#6 /home/happydays/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#7 /home/happydays/public_html/index.php(87): Mage::run('', 'store')
#8 {main}

this is the second time i am getting this error last time i uploaded the backup i had earlier,but i am facing this problem again and again.. This time i lost all my tables from the database... please tell me what would be the possible cause for this.. is there anything in the template i have used... ??

  • Ther are lot of issue in your instance – Amit Bera Nov 30 '14 at 10:06
  • Why did you list both Magento 1.6 and 1.9? – brentwpeterson Nov 30 '14 at 14:07
1

If there were no any changes in Magento code (according to the question it just suddenly occurred for no reason), please contact your host, as the only possible reason would be database corruption or filesystem corruption. Check it with your hosting support and request them to restore the last consistent backup of your site.

Otherwise (in case you installed extensions, changed themes or someone was fixing Magento code), please provide more details.

| improve this answer | |
  • yes the problem is with the host..thanks Alex.. – Pavan Dec 3 '14 at 16:14
0

Your issue is the same as this one: https://stackoverflow.com/questions/17147811/sql-error-core-resource-already-exists

Check solutions described in answers.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.