0

Currently i just upgrade to magento 1.9.1 and using the guide from

http://www.magentocommerce.com/knowledge-base/entry/ee1141-ce191-configurable-swatches

i have upload 2 png file namely Black and White to [your Magento install dir]/media/wysiwyg/swatches.

But under my webpage, it is still showing me a dropdown box instead of swatches? Is it because of the theme that i use which is not compatible to magento 1.9.1 swatches ?

Under my configurable products, the image i have also label to White and Black. What can be wrong.

Many Thanks

2

Try to refresh the Swatch Images Cache. It's a new button under System > Cache Management. Also use lowercase only for swatch image file names, like white.png and black.png

I have also found that swatches only work under the RWD package and not the DEFAULT package which comes with Magento. So if you are using a custom theme, it is very likely that the swatches don't work out of the box. Contact your theme developer to update the theme and integrate swatches.

You could run a test by switching to the RWD package temporarily, to check if swatches then work.

  • I see. Maybe it only applicable for RWD theme like what you suggested. My theme that i am using is a free theme, i doubt they will support =( – Kelvin Low Kok Hoe Dec 1 '14 at 6:49
  • 1
    @KelvinLowKokHoe I got the swatches working for the DEFAULT package. You can find a write-up on how I did this via this link. Maybe this will work for your theme too – ForMat Dec 1 '14 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.