1

I try this with Inchoo Tutorial. This was a common error, I tried to create a configuration to my extension. this is very basic configuration creation with following files.

my Config.xml file : Path(\app\code\local\Wired\Concept\etc)

<?xml version="1.0"?>
<config>
<modules>
    <Wired_Concept>
        <version>0.1.0</version>
    </Wired_Concept>
</modules>
<global>
    <models>
        <concept>
            <class>Wired_Concept_Model</class>
        </concept>
    </models>
    <helpers>
        <concept>
            <class>Wired_concept_Helper</class>
        </concept>
    </helpers>
 </global>
<adminhtml>
<acl>
    <resources>
        <all>
            <title>Allow Everything</title>
        </all>
        <admin>
            <children>
                <system>
                    <children>
                        <config>
                            <children>
                                <wired>
                                    <title>Wired - All</title>
                                </wired>
                            </children>
                        </config>
                    </children>
                </system>
            </children>
        </admin>
    </resources>
</acl>
</adminhtml>
</config>

My system.xml : Path(\app\code\local\Wired\Concept\etc)

<?xml version="1.0" encoding="UTF-8"?>
<config>
<tabs>
    <wired translate="label" module="concept">
        <label>Wired Extensions</label>
        <sort_order>100</sort_order>
    </wired>
</tabs>
<sections>
    <wired translate="label" module="concept">
        <label>Extension Options</label>
        <tab>wired</tab>
        <sort_order>1000</sort_order>
        <show_in_default>1</show_in_default>
        <show_in_website>1</show_in_website>
        <show_in_store>1</show_in_store>
    </wired>
<groups>
<wired_group translate="label" module="concept">
                <label>My Extension Options</label>
                <frontend_type>text</frontend_type>
                <sort_order>1000</sort_order>
                <show_in_default>1</show_in_default>
                <show_in_website>1</show_in_website>
                <show_in_store>1</show_in_store>

                <fields>
                    <wired_input translate="label">
                        <label>My Input Field: </label>
                        <comment>My Comment</comment>
                        <frontend_type>text</frontend_type>
                        <sort_order>20</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                    </wired_input>
                    <wired_select translate="label">
                        <label>My Dropdown: </label>
                        <comment>Source model provider Magento's default Yes/No values</comment>
                        <frontend_type>select</frontend_type>
                        <sort_order>90</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                        <source_model>adminhtml/system_config_source_yesno</source_model>
                    </wired_select>
                </fields>
            </wired_group>
        </groups>
</sections>
</config>

My Data.php Helper File : Path(app\code\local\Wired\Concept\Helper)

<?php
class Wired_Concept_Helper_Data extends Mage_Core_Helper_Abstract
{
}

My Wired_Concept.xml file : Path(app\etc\modules)

<?xml version="1.0" encoding="utf-8"?>
<config>
<modules>
    <Wired_Concept>
        <active>true</active>
        <codePool>local</codePool>
    </Wired_Concept>
</modules>
</config>

I tried several ways and read several pages.But i can't figure out my problem, Definitely i can understand my helper file is missing some thing, with my eye i can't see that. Pls Help me to figure it out.

2

You have declared the Helper class wrongly in config.xml.

Check below for your code snippet

<helpers>
        <concept>
            <class>Wired_concept_Helper</class>
        </concept>
    </helpers>

Here the class should be

<class>Wired_Concept_Helper</class>
  • Thank you.with this edit i can show the configuration bar.But i cant view the extensions options any idea? – Mujahidh Nov 26 '14 at 8:02
  • I am not clear by extensions options.. what do you mean by that? – Dexter Nov 26 '14 at 8:06
  • please have a look at my question edit on system.xml file. – Mujahidh Nov 26 '14 at 8:14
  • i am not clear what is the problem you are facing? – Dexter Nov 26 '14 at 8:16
  • My purpose of the question was achieved with your answer.i tried with this article inchoo.net/magento/… it is apper in the article i can't get the view.If you can please check the image under this line "And if you’ve done everything correctly you should see something like this:" in that inchoo website tutorial.it will be great help.if you cnt view this link pls use the questions link. – Mujahidh Nov 26 '14 at 8:20
2

1.You missed out the closing tag </config> in app\etc\modules\Wired_Concept.xml. So that it not appear in admin configuration section and cause error.

2.You have to close </wired> tag after </groups> tag in \app\code\local\Wired\Concept\etc\system.xml.

Please refer and replace the code below in system.xml

<?xml version="1.0" encoding="UTF-8"?>
<config>
<tabs>
    <wired translate="label" module="concept">
        <label>Wired Extensions</label>
        <sort_order>100</sort_order>
    </wired>
</tabs>
<sections>
    <wired translate="label" module="concept">
        <label>Extension Options</label>
        <tab>wired</tab>
        <sort_order>1000</sort_order>
        <show_in_default>1</show_in_default>
        <show_in_website>1</show_in_website>
        <show_in_store>1</show_in_store>

        <groups>
            <wired_group translate="label" module="concept">
                <label>My Extension Options</label>
                <frontend_type>text</frontend_type>
                <sort_order>1000</sort_order>
                <show_in_default>1</show_in_default>
                <show_in_website>1</show_in_website>
                <show_in_store>1</show_in_store>

                <fields>
                    <wired_input translate="label">
                        <label>My Input Field: </label>
                        <comment>My Comment</comment>
                        <frontend_type>text</frontend_type>
                        <sort_order>20</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                    </wired_input>
                    <wired_select translate="label">
                        <label>My Dropdown: </label>
                        <comment>Source model provider Magento's default Yes/No values</comment>
                        <frontend_type>select</frontend_type>
                        <sort_order>90</sort_order>
                        <show_in_default>1</show_in_default>
                        <show_in_website>1</show_in_website>
                        <show_in_store>1</show_in_store>
                        <source_model>adminhtml/system_config_source_yesno</source_model>
                    </wired_select>
                </fields>
            </wired_group>
        </groups>
    </wired>
</sections>
</config>

Now check in your admin section

  • it was a by mistake, but the config tag is closed in the local file.Thank you. – Mujahidh Nov 26 '14 at 10:00
  • ok. You checked system.xml ? – Venkat Nov 26 '14 at 10:42
  • Yes venkat. The issue was corrected with the first answer.Thank you. – Mujahidh Nov 26 '14 at 10:46
  • sounds good :). – Venkat Nov 26 '14 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.