5

I have a problem with my Magento website.

Because my website was extensively redesigned, notably the home page - I have had the cache disabled on the page for about a month or two.

Now I was able to enable all cache modules except Blocks HTML Output module. When I switch it on, my Magento is displaying the old home page. Sometimes it also says that cache is Invalidated.

Refreshing and flushing cache does nothing. So does the manual deletion of files from var/cache folder.

I am clueless. I've heard that usually, people have a problem with products not showing due to blocks html but this is really confusing. How can I rectify this problem?

4
  • Are you using any other cache?
    – mbalparda
    Nov 25, 2014 at 16:40
  • As mbalparda asked - are you using any other cache as APC, Memcache or Varnish (Varnish makes the most problems)? Also you can check if Compiler is enabled and to disable or recompile it (in the admin panel -> System -> Tools -> Compilation).
    – michael
    Nov 25, 2014 at 18:43
  • All other cache are now enabled only blocks html output is disabled
    – Greg
    Nov 26, 2014 at 10:10
  • I also have ezzoom plugin in operation
    – Greg
    Nov 26, 2014 at 10:10

1 Answer 1

2

You may be using an alternative cache backend, in which case, using the Flush Cache Storage button should be sufficient to empty the cache contents.

If you are using a cache backend that doesn't support tagging (eg. Memcache), then conditionally flushing caches isn't going to work (unless you are using two-level caching).

You can verify the cache backend by looking in your ./app/etc/local.xml file between the <cache/> tags.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.