0

I copied all the files from live server to local xampp server. when I run the url, getting below tmp error. How to resolve the issue?

Notice: Use of undefined constant tmp - assumed 'tmp'  in C:\xampp\htdocs\shopmyga\lib\Zend\Cache.php on line 153

#0 C:\xampp\htdocs\shopmyga\lib\Zend\Cache.php(153): mageCoreErrorHandler(8, 'Use of undefine...', 'C:\xampp\htdocs...', 153, Array)
#1 C:\xampp\htdocs\shopmyga\lib\Zend\Cache.php(94): Zend_Cache::_makeBackend('File', Array, true, true)
#2 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Model\Cache.php(137): Zend_Cache::factory('Varien_Cache_Co...', 'File', Array, Array, true, true, true)
#3 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Model\Config.php(1348): Mage_Core_Model_Cache->__construct(Array)
#4 C:\xampp\htdocs\shopmyga\app\Mage.php(463): Mage_Core_Model_Config->getModelInstance('core/cache', Array)
#5 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Model\App.php(401): Mage::getModel('core/cache', Array)
#6 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Model\App.php(295): Mage_Core_Model_App->_initCache(Array)
#7 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Model\App.php(337): Mage_Core_Model_App->baseInit(Array)
#8 C:\xampp\htdocs\shopmyga\app\Mage.php(684): Mage_Core_Model_App->run(Array)
#9 C:\xampp\htdocs\shopmyga\index.php(87): Mage::run('', 'store')
#10 {main}

After done the changes, now I am getting below error when login as admin:

Warning: Header may not contain more than a single header, new line detected.  in C:\xampp\htdocs\shopmyga\lib\Zend\Controller\Response\Abstract.php on line 360

#0 [internal function]: mageCoreErrorHandler(2, 'Header may not ...',   'C:\xampp\htdocs...', 360, Array)
#1 C:\xampp\htdocs\shopmyga\lib\Zend\Controller\Response\Abstract.php(360): header('Location: http:...', true, 302)
#2 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Controller\Response\Http.php(78): Zend_Controller_Response_Abstract->sendHeaders()
#3 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Controller\Response\Http.php(115):  Mage_Core_Controller_Response_Http->sendHeaders()
#4 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Admin\Model\Session.php(135): Mage_Core_Controller_Response_Http->sendHeadersAndExit()
#5 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Admin\Model\Observer.php(69): Mage_Admin_Model_Session->login('surestce', '12345678', Object(Mage_Core_Controller_Request_Http))
#6 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Model\App.php(1338): Mage_Admin_Model_Observer->actionPreDispatchAdmin(Object(Varien_Event_Observer))
#7 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Model\App.php(1317): Mage_Core_Model_App->_callObserverMethod(Object(Mage_Admin_Model_Observer), 'actionPreDispat...', Object(Varien_Event_Observer))
#8 C:\xampp\htdocs\shopmyga\app\Mage.php(448): Mage_Core_Model_App->dispatchEvent('controller_acti...', Array)
#9 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Controller\Varien\Action.php(527): Mage::dispatchEvent('controller_acti...', Array)
#10 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Adminhtml\Controller\Action.php(160): Mage_Core_Controller_Varien_Action->preDispatch()
#11 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Controller\Varien\Action.php(407): Mage_Adminhtml_Controller_Action->preDispatch()
#12  C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Controller\Varien\Router\Standard.php(250): Mage_Core_Controller_Varien_Action->dispatch('index')
#13 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Controller\Varien\Front.php(172): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
 #14 C:\xampp\htdocs\shopmyga\app\code\core\Mage\Core\Model\App.php(354): Mage_Core_Controller_Varien_Front->dispatch()
 #15 C:\xampp\htdocs\shopmyga\app\Mage.php(684): Mage_Core_Model_App->run(Array)
 #16 C:\xampp\htdocs\shopmyga\index.php(87): Mage::run('', 'store')
 #17 {main}
2
  • Did you delete all your cache files in C:\xampp\htdocs\shopmyga\var\cache Nov 22, 2014 at 19:44
  • yes. I deleted all my cache files (\var\cache) and session files (\var\session) Nov 24, 2014 at 6:06

2 Answers 2

2

Please check the file path [rootfolder]\lib\Zend\Cache\Backend.php and line number 174.

Go through the function getTmpDir and check you have sufficient permission for tmp folder and access to write files in tmp

0

compile your website and clear cache and disable developer mode use cmd to do this php shell/compiler.php --clear php shell/compiler.php --compile php shell/indexer.php --reindex

reload your website and if OK run php shell/compiler.php --disable

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.