0

I have a label for my custom payment method in the config.xml file. It looks like this:

<default>
    <payment>
        <cashpayment translate="title" module="paygate">
            <active>1</active>
            <model>payments/cash</model>
            <order_status>1</order_status>
            <title>Cash Payment</title>
        </cashpayment>
    </payment>
</default>

Unfortunately, despite 'translate' parameter the output in the front end is still 'Cash Payment'. I've updated translation file, flushed the cache but it didn't help. Any suggestions would be highly appreciated :)?

2

This will try to translate using Mage::helper('paygate')->__('Cash Payment').

paygate is the alias of Mage_Paygate, so your translation must be defined either

  1. in Mage_Paygate.csv
  2. in the translate.csv of your theme as "Mage_Paygate::Cash Payment","Your translation here"
  3. in the database, using inline translation
0
  1. Make sure that your front end is set to the correct locale which you made the translations. System->Configuration. Change Current Configuration Scope to the Correct Front End Store. Under General Tab->Locale Options.
  2. Systems->Cache Management Refresh Magento Cache for all Cache Types, Flush Magento Cache & Flush Cache Storage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.