1

I have installed comodo ev certificate... no problem everything works.

The issue arises when i activate it in the store

i set the secure url as it is supposed to and also change for front an back end.

The issue is that when i go to account login page in chrome it displays the green address bar but in firefox i get a warning sign that the page would contain unsafe material, also in opera it gives a message that some material is blocked and in safari it doesn't show the certificate at all

What should i do to solve these issues?

in console i see this message, but when checking page source i can not find it at all... where would i need to check to adjust or remove this?

[blocked] The page at 'https://www.domain.com/customer/account/login/' was loaded over HTTPS, but ran insecure content from 'http://fonts.googleapis.com/css?family=Lato:400,100,300,700,100italic,900,400italic,300italic,700italic,900italic': this content should also be loaded over HTTPS.

thanks

2
  • Check the certificate data. Maybe the encryption is too low or the encryption method does not meet the firefox requirements to recognise it as "safe". – Anna Völkl Nov 19 '14 at 13:56
  • Certificate data is ok... checked it with company i purchased it. just discovered that when checking console in firefox i get 2 warnings about google fonts (that i don't even use in my store but came with theme appearantly)... these load with http:// instead of // or https:// What file could i check to remove these? – carlo Nov 19 '14 at 14:05
3

I found the issue... it was in css file for theme and after changing that it worked... thought it might be good to place it here so if anyone else would have the issue they will check css also

1

first you have to check your setup with:
https://ssllabs.com/ssltest

then you have to separate two error sources:
a. certificate chain issues
b. hardcoded protocol in templates.

2
  • please check edited post above with what i found – carlo Nov 19 '14 at 14:23
  • yes, this is option b. hardcoded proto. – user2857 Nov 19 '14 at 17:47
0

I would suggest to go to firefox and right click and click on view page source then search this-

http://

if you find any, then you need to change this to https:// OR //.

If you don't find this then, it must be in your some of css file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.