I can not get the first line of the address in receiver and sender address in sales -> order. enter image description here

But when I click edit, it displays all the address line which I have given

enter image description here

Now I want to display the first line address in street address field in 1st line in the first image I have uploaded in back-end(admin). Kindly help me!! Spending more than 3 days:(

  • Just an idea: Maybe the "#" is interpreded as comment somewhere. Did you check your source-code? Nov 17, 2014 at 8:38
  • Nope, tried that. Works for me. Nov 17, 2014 at 8:39
  • its coming in local.i have also checked it.but in some case it is not displaying Nov 17, 2014 at 8:46
  • @ Anna Völkl other than # is also not displaying Nov 17, 2014 at 8:48

1 Answer 1


The address layout is build thru the System->Configuration->Customer Configuration->Address Template configuration page. The Sales Order page uses the HTML Template, so check if the street1 line is included there. The default template for the HTML format is:

{{depend prefix}}{{var prefix}} {{/depend}}{{var firstname}} {{depend middlename}}{{var middlename}} {{/depend}}{{var lastname}}{{depend suffix}} {{var suffix}}{{/depend}}<br/>
{{depend company}}{{var company}}<br />{{/depend}}
{{if street1}}{{var street1}}<br />{{/if}}
{{depend street2}}{{var street2}}<br />{{/depend}}
{{depend street3}}{{var street3}}<br />{{/depend}}
{{depend street4}}{{var street4}}<br />{{/depend}}
{{if city}}{{var city}},  {{/if}}{{if region}}{{var region}}, {{/if}}{{if postcode}}{{var postcode}}{{/if}}<br/>
{{var country}}<br/>
{{depend telephone}}T: {{var telephone}}{{/depend}}
{{depend fax}}<br/>F: {{var fax}}{{/depend}}
{{depend vat_id}}<br/>VAT: {{var vat_id}}{{/depend}}

The configuration option is added in a later version (not sure when), so its also possible that the address template is used from the database table directory_country_format (where type=html).

  • ok @Vladimir Kerkhoff.I'll check it Nov 17, 2014 at 8:53
  • Perfect it works me @Vladimir Kerkhoff Nov 17, 2014 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.