-1

Today I changed one magento to another server. But I have one problem:

In the new server, all my products have automatically set:

  • special price to 0.00
  • all data fields to: 30/11/2000

In categories the field:

  • Layered Navigation Price Step is set to 0.00
  • All data field to 30/11/2000

I put this in the top of sql import field:

SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";
SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT;
SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS;
SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION;
SET NAMES utf8;
SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0;
SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0;
SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO';
SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0;

And this in the bottom:

SET SQL_MODE=@OLD_SQL_MODE;
SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS;
SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS;
SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT;
SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS;
SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION;
SET SQL_NOTES=@OLD_SQL_NOTES;

If not the import give me errros.

What is the problem?

Edit:

SQL dumb:

CREATE TABLE `de5frs_catalog_product_flat_1`
...
`special_price` decimal(12,4) DEFAULT NULL COMMENT 'special_price',
`special_to_date` datetime DEFAULT NULL COMMENT 'special_to_date',
`tax_class_id` int(10) unsigned DEFAULT NULL COMMENT 'tax_class_id',
...

And the data table are empty.

  • Did you do a reindex after importing? – Sander Mangel Nov 13 '14 at 10:42
  • Did that solve it you mean? – Sander Mangel Nov 13 '14 at 11:03
  • No, sorry, I mean that i reindexing before posting here. Sorry. I still searching a solution. – MilimetricMKT Nov 13 '14 at 11:12
  • Did you check the database dump which you created before if the values in there are right? How did you create the dump which was imported? – Anna Völkl Nov 13 '14 at 11:41
  • I add some dumb info on the post. I use XCloner to do the backup (files and DB). – MilimetricMKT Nov 13 '14 at 12:05
0

I would export all products before moving to new server as well as backup the database. Then I would import the database like you did and if this doesn't help, I would import all the products from previous exported file.

From System > Import/Export > Import

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.