I am new to magento platform. Unfortunately i had executed the Run complier in enable status mode so my customized codes are removed from include folder.Although and i recovered the customize files from my backups but the complier status is always "disable". I have tried to enable "Compilation" in Magento admin panel. When i do so, the site goes blank and to fix this i commented the line below in the config file in "include" folder .


then the admin panel works fine but still complier status is in disabled mode. so i have commented the below code in index.php file (root folder)

$compilerConfig = 'includes/config.php'; if (file_exists($compilerConfig)) { include $compilerConfig; } and then I click enable button then admin is works fine and it shows "Compiler include path is enabled" meassage, But magento "Compiler Status" shows "Disable" and button shows "Enable" option in top right.

How to fix this issue in admin panel? Please suggest me to solve this problem?

if there is any tables to change the status ? if possible please tell me the tables with update query.


  • Make sure you have write access on the file includes/config.php.
    – Marius
    Commented Nov 12, 2014 at 9:26
  • yap. i have gave access permission on folder as 0777. if else could you please suggest me ? Commented Nov 12, 2014 at 9:30
  • 1
    For some servers, the file permission 777 is a security risk and will not work. Try using 755 if your server is using SuPHP or SuExec. Commented Nov 12, 2014 at 9:38
  • The compilers shows as disabled when the constant COMPILER_INCLUDE_PATH is not defined. And in your case is not because you commented the line that defines it. You stated so in the question.
    – Marius
    Commented Nov 12, 2014 at 9:40
  • Hi Marius, thanks for ur rply. if the "COMPILER_INCLUDE_PATH" code is not commented the scrn is displays blank and site frontend also.. please suggest me what can i do for it ?? Commented Nov 12, 2014 at 9:46

3 Answers 3


customized codes are removed from include folder

Did I understand that correct and you made modifications to the compiled Magento files? Sorry to break it to you but this is wrong on several levels.

  • never ever modify core files of Magento, this is not necessary in any case and always leads to problems (losing your ability to upgrade being the main issue)
  • never change generated files because they will be overwritten (this is not Magento related, more like common sense)
  • Don't use the Magento compiler. It brings more pain than benefit. See also: When should I use the Magento Compiler

Also, do yourself a favor and put your code in version control. You should not rely on backups if it comes to tracking and recovering changes.

  • Hi fschmengler, thanks for ur rply. i had remove my customized code form include folder but no luck yet didnt change the status as enable.. please suggest me.. thanks for advance. Commented Nov 14, 2014 at 14:29

I also faced this issue, now I fixed it.

My my site/includes/config.php file is empty.Now I copied this file from my another 1.9 Magento extension and placed it here.Now its working fine for me.


I had this issue. It was due to an error in includes/config.php It works now with the following in:



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.