I'm trying to help a friend migrate his magento site to a new host. I exported the DB, zipped the site files and moved everything over. There was a hiccup with the SQL on import, but I found a fix.

The DNS propagated and the front end works great, but the admin gives: https://sitedomain.com/index.php/admin. I try just /admin, and it redirects to that with this error:

The server can not find the requested page:

sitedomain.com/index.php/admin (port 443)

I've tried every fix you can find via google - running this:

UPDATE `core_store` SET store_id = 0 WHERE code='admin';
UPDATE `core_store_group` SET group_id = 0 WHERE name='Default';
UPDATE `core_website` SET website_id = 0 WHERE code='admin';
UPDATE `customer_group` SET customer_group_id = 0 WHERE customer_group_code='NOT LOGGED IN';

...clearing caches, setting admin SSL to 0 from 1, nothing.


Do make sure that the default ".htaccess" file for Magento is copied over as well as it is always missed out due to it being a hidden dot file.

If you are sure that the proper ".htaccess" file is in place, make sure that the server's mod_rewrite is working properly.

  • Thanks - I was able to copy over .htaccess with the rest of the site files, and just checked on it, 'RewriteEngine on' is entered in it. I did also create a test.php file with phpinfo(); in it, but don't see mod_rewrite there. – bmac Nov 10 '14 at 14:30
  • You may want to check with the hosting provider on whether mod_rewrite is enabled in the server and working properly. – Aspiration Hosting Nov 11 '14 at 5:59
  • Thank you, did exactly that. It was in fact related to .htaccess - I had the mod_rewrite line in, but the rewrite base line was incorrect. Thanks! – bmac Nov 11 '14 at 14:12
  • Glad to hear that it's resolved now! – Aspiration Hosting Nov 12 '14 at 7:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.