1

I've been editing within catalog/view/options/type/configurable.phtml and this other guy working on the template has been editing all over the place. Suddenly, the whole configurable options block (that renders configurable.phtml) went missing from the page. The following blocks are still in view.phtml:

<?php if ($_product->isSaleable() && $this->hasOptions()):?>
                <?php echo $this->getChildChildHtml('container1', '', true, true) ?>
            <?php endif;?>

and

<?php if ($_product->isSaleable() && $this->hasOptions()):?>
                <?php echo $this->getChildChildHtml('container2', '', true, true) ?>
            <?php endif;?>

What else might be missing that would cause the disappearance of the configurable options block? There are no errors in the server or Magento logs that are applicable. Nor any JavaScript errors.

1
  • Have you tested your exact same database on a fresh install of Magento? If the same thing happens it's pointing towards an issue with a setting somewhere. Jun 22, 2016 at 14:43

1 Answer 1

1

Was any changes made to /app/design/frontend/default/[default]/layout/catalog.xml?

<catalog_product_view translate="label">
 .....
            <block type="core/template_facade" name="product.info.container1" as="container1">
                <action method="setDataByKey"><key>alias_in_layout</key><value>container1</value></action>
                <action method="setDataByKeyFromRegistry"><key>options_container</key><key_in_registry>product</key_in_registry></action>
                <action method="append"><block>product.info.options.wrapper</block></action>
                <action method="append"><block>product.info.options.wrapper.bottom</block></action>
            </block>
            <block type="core/template_facade" name="product.info.container2" as="container2">
                <action method="setDataByKey"><key>alias_in_layout</key><value>container2</value></action>
                <action method="setDataByKeyFromRegistry"><key>options_container</key><key_in_registry>product</key_in_registry></action>
                <action method="append"><block>product.info.options.wrapper</block></action>
                <action method="append"><block>product.info.options.wrapper.bottom</block></action>
            </block>
            <action method="unsetCallChild"><child>container1</child><call>ifEquals</call><if>0</if><key>alias_in_layout</key><key>options_container</key></action>
            <action method="unsetCallChild"><child>container2</child><call>ifEquals</call><if>0</if><key>alias_in_layout</key><key>options_container</key></action>
8
  • Nope! Replaced it with a fresh file from the latest version Magento and no changes! May 31, 2013 at 14:53
  • Did you check to make sure the if statement return true May 31, 2013 at 14:59
  • Nope. Just took the code within the if statements above and dragged them outside of the if block and no change. I'm cntrl+shift+refreshing to make sure the page isn't cacheing and I know its not cacheing in the Magento system either. May 31, 2013 at 15:18
  • And if you view page source of the code on the product detail page, it shows the code I have in configurable.phtml as commented out! May 31, 2013 at 16:05
  • 1
    @CaitlinHavener I have the same issue. Were you able to track it down? May 12, 2015 at 17:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.