Here is my question in stackoverflow: https://stackoverflow.com/questions/26771070/an-error-occurred-while-processing-this-directive-after-upgrade-magento-from-1.

I just updated magento from 1.5 to 1.9 by this way: - Go to magento connect and install package: http://connect20.magentocommerce.com/community/Mage_All_Latest.

After that, I got an error like this: CONNECT ERROR: Package community/Mage_Core_Modules conflicts with: community/Mage_GoogleShopping 0.3.5, community/Ansyori_Autotrans 0.1.0 Package 'Lib_Google_Checkout' is invalid Empty package contents section

And then, when I go to my website, it always gets this error: [an error occurred while processing this directive]

I try many ways: reset permission, change User name but nothings change. Anyone can help me ?

  • Have you tried disabling the two modules (community/Mage_GoogleShopping 0.3.5 & community/Ansyori_Autotrans 0.1.0)? Nov 6, 2014 at 8:44
  • @HungDQ .. Sorry it is too late. If you remember Can you please confirm what was the issue on server side ? As I am getting the same error Jun 1, 2015 at 7:00
  • It's permission problem, but I cannot remember how to fix it :(
    – HungDQ
    Jun 1, 2015 at 10:25

3 Answers 3


Do you have a backup before you upgrade?

If you do, I suggest that you roll back and attempt it again but this time try to do it step-by-step from 1.5 to 1.6 to 1.7 to 1.8 and finally to 1.9 instead of going directly from 1.5 to 1.9.

What I suggest is for you to create a staging store and attempt the upgrade from there.

You should also take multiple backups to make it easy to roll back if required.

After taking your backup, attempt the upgrade from 1.5 to 1.6 and check if everything works fine. If it does, continue step-by-step until you are at 1.9. If something broke in between, find out if there's any code changes which may affect your theme or extensions which are not compatible and attempt to correct them first before you continue.

  • Thank you @Aspi, My problem is the server, I just fixed it.
    – HungDQ
    Nov 11, 2014 at 1:37
  • Sounds good. Happy to see that the server issue is resolved. :) Nov 11, 2014 at 5:55

It happens in bluehost while magento installation even after setting proper file/folder permissions. Remove .htaccess and try.


Fixed by setting correct folders and files permission. Using SSH within the magento folder type that commands

find . -type d -exec chmod 755 {} \;
find . -type f -exec chmod 644 {} \;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.