0

I am using the WSDL (advertised in the Magento Website to be used with Java) in my Android Application.

For simulating the request/response i am using SOAP UI. I deployed Magento on a WAMP server on my local windows machine.

Now when i run any of the SOAP API's I am getting a SOAP fault. Upon analysis found that the below line present in all the internal WSDL files in magento is the cause of this problem -

<import namespace="http://schemas.xmlsoap.org/soap/encoding/" schemaLocation="http://schemas.xmlsoap.org/soap/encoding/" />

When I comment this line, everything seems to work fine. But I don't think that this is the correct solution ...

Anyone who faced this issue , please help out !!!!!

1

I think the problem is the SoapUI application not the wsdl itself. I can confirm that the wsdl file is valid.
I don't know if this is the issue for you, but I had an encoding problem related to SoapUI and it was solved by adding this:

-Dfile.encoding=UTF8

inside oapUI-4.6.4\bin\SoapUI-4.6.4.vmoptions. The folder and file name may depend on the SoapUI version.

  • I will slightly modify my question here. I invoked this SOAP Api's from java code (Using KSoap). I face the same issue.So i guess the issue might not be specific to SOAP UI – Dibzmania Nov 5 '14 at 13:19
  • @Dibzmania. You might be right. I was just shooting in the dark. One thing is clear. I was able to use the wsdl with php and java. Sorry I cannot do more. – Marius Nov 5 '14 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.