0

I am setting up a second language store. We use the same root category. What I do is the following: I open the store view of the second language and want to start translating.

The weirdest thing: the checkbox in store view to "Use Default Value" (and thus override defaults) is completely missing. Now I would not know how to translate ...

question: is there a setting? or soemthing I need to do to enable the translation per store view in categories again?

Or has anyone seen this before?

many thanks


Examples

What I would expect to see

What I would expect to see

What we are currently seeing - notice the missing checkbox

What we are currently seeing - notice the missing checkbox

1

The form elements should be displayed using this template app/design/adminhtml/default/default/template/catalog/form/renderer/fieldset/element.phtml (unless you changed that, but I doubt you did).
There is an if statement for displaying the checkbox.

<?php if ($this->canDisplayUseDefault()): ?>
<td class="value use-default">
    <input <?php if($_element->getReadonly()):?> disabled="disabled"<?php endif; ?> type="checkbox" name="use_default[]" id="<?php echo $_element->getHtmlId() ?>_default"<?php if ($this->usedDefault()): ?> checked="checked"<?php endif; ?> onclick="toggleValueElements(this, this.parentNode.parentNode)" value="<?php echo $this->getAttributeCode() ?>"/>
    <label for="<?php echo $_element->getHtmlId() ?>_default" class="normal"><?php echo $this->__('Use Default Value') ?></label>
</td>
<?php endif; ?>

So my guess is that $this->canDisplayUseDefault() returns false for some reason.
The method is defined in Mage_Adminhtml_Block_Catalog_Form_Renderer_Fieldset_Element

public function canDisplayUseDefault()
{
    if ($attribute = $this->getAttribute()) {
        if (!$attribute->isScopeGlobal()
            && $this->getDataObject()
            && $this->getDataObject()->getId()
            && $this->getDataObject()->getStoreId()) {
            return true;
        }
    }
    return false;
}

Start debugging here to see what's wrong.

Solution (provided by OP based on the indications from the answer): Using the above you can discover a Module or Extension that is causing problems. In this case disabling "https://github.com/mage-eag/mage-enhanced-admin-grids" solved the issue.

  • super! I will investigate and post the resolution – snh_nl Oct 31 '14 at 13:13
  • @snh_nl. Yeah..I forgot to mention, this is not a full solution. I wasn't able to reproduce it. And my answer did not fit in a comment. – Marius Oct 31 '14 at 13:17
  • The problem was actually related to another extension (BubbleShop Dynamic Category Products) and not to Enhanced Admin Grids, as explained here : github.com/mage-eag/mage-enhanced-admin-grids/issues/… – blmage Nov 4 '14 at 9:02
0

If I understood your problem correctly, please follow the below mentioned procedure and you'll be good to go with your translation!

  • Go to System -> Configuration -> General -> Locale Options
  • Change configuration scope to your New Storeenter image description here
  • Then select the language you want to assign at Locale Options -> Locale
  • Now, Clear cache and check in front-end
  • euh. I know how to change my default language. The question is why the option to override default values in store view (checkbox) under categories is missing – snh_nl Oct 31 '14 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.