1

To create test site for copy of live store,

  • Copy all files (except some media files)

  • Dump and Import database

  • Clear all cache (rm -rf newdomain/www/var/*)

  • Update base url

UPDATE core_config_data SET value="http://newdomain.com" WHERE path=’web/secure/base_url’;

UPDATE core_config_data SET value="http://newdomain.com" WHERE path=’web/unsecure/base_url’;

(also checked select * from core_config_data where path like '%base_url%')

  • Update local.xml file (for connecting test db, db user, password)

  • Check root's htaccess file (I even try to delete the file)

  • Asked server support , they said it's web source problem , not server setting

I think I did everything I know and search to solve! but still when I visit my test website, it still redirect my live web site

Am I missing something? What I should check more?

7
  • Url should have the '/' after '.com'. eg http://newdomain.com/ Oct 29 '14 at 5:07
  • Also the page may be cache, did you test in a different browser? Oct 29 '14 at 5:09
  • @R.S I just checked again, my url clearly have '.com/' on core_config_data Thanks anyway
    – Yohan
    Oct 29 '14 at 5:12
  • @R.S Yes I tried different browser, clear browser cache, even tried with other computer
    – Yohan
    Oct 29 '14 at 5:13
  • 1
    I know you cleared cache by deleting files, but isbit posible you have folder permission issue, and cache is going to /tmp? What happens if you disable cache (use n98-magerun from cli)
    – ProxiBlue
    Oct 29 '14 at 5:37
2

Comment copied to answer to allow this question to be marked answered, and not left hanging open, as it is solved.

I know you cleared cache by deleting files, but is it possible you have folder permission issue, and cache is going to /tmp?

What happens if you disable cache? (use n98-magerun from cli)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.